dp背包价值过大的求解,结果关键在“优化”

A Bank plans to install a machine for cash withdrawal. The machine is able to deliver appropriate @ bills for a requested cash amount. The machine uses exactly N distinct bill denominations, say Dk, k=1,N, and for each denomination Dk the machine has a supply of nk bills. For example,

N=3, n1=10, D1=100, n2=4, D2=50, n3=5, D3=10

means the machine has a supply of 10 bills of @100 each, 4 bills of @50 each, and 5 bills of @10 each.

Call cash the requested amount of cash the machine should deliver and write a program that computes the maximum amount of cash less than or equal to cash that can be effectively delivered according to the available bill supply of the machine.

Notes:
@ is the symbol of the currency delivered by the machine. For instance, @ may stand for dollar, euro, pound etc.
Input
The program input is from standard input. Each data set in the input stands for a particular transaction and has the format:

cash N n1 D1 n2 D2 ... nN DN

where 0 <= cash <= 100000 is the amount of cash requested, 0 <=N <= 10 is the number of bill denominations and 0 <= nk <= 1000 is the number of available bills for the Dk denomination, 1 <= Dk <= 1000, k=1,N. White spaces can occur freely between the numbers in the input. The input data are correct.
Output
For each set of data the program prints the result to the standard output on a separate line as shown in the examples below.
Sample Input
735 3  4 125  6 5  3 350
633 4  500 30  6 100  1 5  0 1
735 0
0 3  10 100  10 50  10 10
Sample Output
735
630
0
0

这道题中的价值太大,解法就是01背包或者完全背包,但是需要优化!

因为其中在每次循环中,对于大于现阶段的最大能获得的值的dp数组是不用扫过的,因为它们全为0,即使扫过一遍也无法更新其他值,于是在第二个循环用ans代替了cash

结果就顺利ac

贴下代码:

#include <stdio.h>
#include <iostream>
#include <cstring>
#include <stdlib.h>
#include <algorithm>
#include <queue>
#include <math.h>
#define INF 1e8

using namespace std;
//FILE *fp;
int n,cash;
struct P{
    int val,vol;
}s[15];
int dp[100005];
int ans;
int main(void)
{
    //fp=fopen("123.txt","r");
    while (scanf("%d %d",&cash,&n)!=EOF)
    {
        for (int i = 0;i < n;i++)
            scanf("%d %d",&s[i].vol,&s[i].val);
        memset(dp,0,sizeof(dp));
        dp[0]=1;
        ans = 0;
        for (int i = 0;i < n;i++)
        {
            for (int j = ans;j >=0 ;j--)
            {
                if(dp[j])
                {
                    for (int k = 1;k <= s[i].vol;k++)
                    {
                        if(j+k*s[i].val<=cash&&dp[j+k*s[i].val]!=1)
                        {
                            dp[j+k*s[i].val]=1;
                            ans=max(j+k*s[i].val,ans);
                        }
                    }
                }
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}

cheer up!!!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值