HDU 1729 Stone Game(博弈 + SG函数)

227 篇文章 0 订阅
23 篇文章 0 订阅

传送门

Stone Game

Time Limit: 5000/1000 MS (Java/Others)    Memory Limit: 65535/32768 K (Java/Others)
Total Submission(s): 3240    Accepted Submission(s): 1028


Problem Description
This game is a two-player game and is played as follows:

1. There are n boxes; each box has its size. The box can hold up to s stones if the size is s.
2. At the beginning of the game, there are some stones in these boxes.
3. The players take turns choosing a box and put a number of stones into the box. The number mustn’t be great than the square of the number of stones before the player adds the stones. For example, the player can add 1 to 9 stones if there are 3 stones in the box. Of course, the total number of stones mustn’t be great than the size of the box.
4.Who can’t add stones any more will loss the game.

Give an Initial state of the game. You are supposed to find whether the first player will win the game if both of the players make the best strategy.
 

Input
The input file contains several test cases.
Each test case begins with an integer N, 0 < N ≤ 50, the number of the boxes.
In the next N line there are two integer si, ci (0 ≤ ci ≤ si ≤ 1,000,000) on each line, as the size of the box is si and there are ci stones in the box.
N = 0 indicates the end of input and should not be processed.
 

Output
For each test case, output the number of the case on the first line, then output “Yes” (without quotes) on the next line if the first player can win the game, otherwise output “No”.
 

Sample Input
  
  
3
2 0
3 3
6 2
2
6 3
6 3
0
 

Sample Output
  
  
Case 1:
Yes
Case 2:
No

题目大意:

n 个盒子,每个盒子有一个大小是 si,在游戏开始的时候,盒子里有一些石头 ci ,现在有两个玩家,每个玩家选一个盒子然后往里面添加石头,

然后添加石头有一个条件只能添加 1xc2i ,如果谁不能添加谁就输了。

解题思路:

首先我们选择一个必败点:

tmp+tmptmp<n   &&   n(tmp+1)+(tmp+1)(tmp+1)

1):然后当盒子中的石头个数 ci = tmp 的时候先手必败。

2):然后当盒子中的石头个数 tmp < ci 的时候先手必胜。

3):然后当盒子中的石头个数 ci < tmp 的时候状态未知。

然后根据这个就可以写出一个 SG 函数:

ci > tmp 的时候 return sici

ci = tmp 的时候 return 0

ci < tmp 的时候 returnSG(tmp,ci) (si,ci) 的状态跟 (tmp,ci) 的状态相同。

My Code

/**
2016 - 09 - 02 晚上
Author: ITAK

Motto:

今日的我要超越昨日的我,明日的我要胜过今日的我,
以创作出更好的代码为目标,不断地超越自己。
**/

#include <iostream>
#include <cstdio>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include <algorithm>
#include <set>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const int INF = 1e9+5;
const int MAXN = 1e5+5;
const int MOD = 1e9+7;
const double eps = 1e-7;
const double PI = acos(-1);
using namespace std;
LL Scan_LL()///输入外挂
{
    LL res=0,ch,flag=0;
    if((ch=getchar())=='-')
        flag=1;
    else if(ch>='0'&&ch<='9')
        res=ch-'0';
    while((ch=getchar())>='0'&&ch<='9')
        res=res*10+ch-'0';
    return flag?-res:res;
}
int Scan_Int()///输入外挂
{
    int res=0,ch,flag=0;
    if((ch=getchar())=='-')
        flag=1;
    else if(ch>='0'&&ch<='9')
        res=ch-'0';
    while((ch=getchar())>='0'&&ch<='9')
        res=res*10+ch-'0';
    return flag?-res:res;
}
void Out(LL a)///输出外挂
{
    if(a>9)
        Out(a/10);
    putchar(a%10+'0');
}
int get_SG(int s, int c)
{
    int tmp = sqrt(s);
    while(1)
    {
        if(tmp+tmp*tmp<s && (tmp+1)+(tmp+1)*(tmp+1)>=s)
            break;
        tmp--;
    }
    if(tmp < c)
        return s-c;
    if(tmp == c)
        return 0;
    return get_SG(tmp, c);
}
int main()
{
    int n, cas = 1;
    while(cin>>n,n)
    {
        int ans = 0, s, c;
        for(int i=0; i<n; i++)
        {
            cin>>s>>c;
            ans ^= get_SG(s, c);
        }
        if(ans)
            printf("Case %d:\nYes\n",cas++);
        else
            printf("Case %d:\nNo\n",cas++);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值