1004,1020

Problem Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges’ favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) – the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.

Sample Input

5
green
red
blue
red
red
3
pink
orange
pink
0

Sample Output

red
pink


主要在循环,通过两层循环来遍历,字符串数组是二维的,一个控制字符串的个数,一个控制字符串的长度。

#include<cstdio>
#include<cstring>

int main()
{
    int n;

    while (scanf ("%d",&n) && n)
    {
        char s[1005][20];
        int i,j;

        for (i=0; i<n; i++)
        {
            scanf ("%s",s[i]);
        }

        int coun[1005]={0};

        for (i=0; i<n; i++)
        {
            for (j=0; j<n; j++)
            {
                if (strcmp(s[i],s[j]) == 0)
                {
                     coun[i]++;
                }
            }
        }

        int x = 0;

        for (i=0; i<n; i++)
        {
            if (coun[i] > x)
            {
                x = i;
            }
        }

        printf ("%s\n",s[x]);
    }
    return 0;
}

Problem Description

Given a string containing only ‘A’ - ‘Z’, we could encode it using the following method:

  1. Each sub-string containing k same characters should be encoded to “kX” where “X” is the only character in this sub-string.

  2. If the length of the sub-string is 1, ‘1’ should be ignored.

Input

The first line contains an integer N (1 <= N <= 100) which indicates the number of test cases. The next N lines contain N strings. Each string consists of only ‘A’ - ‘Z’ and the length is less than 10000.

Output

For each test case, output the encoded string in a line.

Sample Input

2
ABC
ABBCCC

Sample Output

ABC
A2B3C


#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;

int main()
{
    int n;
    scanf ("%d",&n);

    while (n--)
    {
        int ans;
        int i;
        char s[10005];

        scanf ("%s",s);

        int len = strlen(s);

        for (i=0; i<len;)
        {
            ans = 1;
            while (s[i] == s[i+1])
            {
                ans++;
                i++;
            }

            if (ans == 1)
            {
                printf ("%c",s[i]);
            }
            else
            {
                printf ("%d%c",ans,s[i]);
            }
            i++;
        }
        printf ("\n");

    }
    return 0;
}

这两道题类似,不同是是第一题是整体几个字符串判断,而第二题是单个字符串从前到后依次字符计数,每个字符串都单独处理,单独输出。需要注意题目要求累加计数的是连续的字符,即具有相同字符的字串的长度,如AAADSSAAA,输出是3AD2S3A,而不是6A,循环过程中i的值要仔细用实例推断,看在哪里++。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值