题目1004:Median

题目描述:

    Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1={11, 12, 13, 14} is 12, and the median of S2={9, 10, 15, 16, 17} is 15. The median of two sequences is defined to be the median of the non-decreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.
    Given two increasing sequences of integers, you are asked to find their median.

输入:

    Each input file may contain more than one test case.
    Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤1000000) is the size of that sequence. Then N integers follow, separated by a space.
    It is guaranteed that all the integers are in the range of long int.

输出:

    For each test case you should output the median of the two given sequences in a line.

样例输入:
4 11 12 13 14
5 9 10 15 16 17
样例输出:
13

<span style="font-family:Courier New;">/*------------------------1004----------------------
description:Each input file may contain more than one test case.
            Each case occupies 2 lines, each gives the information 
            of a sequence. For each sequence, the first positive integer 
            N (<1000000) is the size of that sequence. Then N integers follow
            separated by a space.
author     :yuanwei
time       :2013-02-12
--------------------------1004----------------------*/
 
#include <stdio.h>
#include <malloc.h>
 
//find the media number of the matrix a and the matrix b
int getMedia(long int *a, int lenOfA, long int *b, int lenOfB)
{
    int i = 0;
    int j = 0;
    int r = 0;
    long int *c = (long int *)malloc(sizeof(long int) * (lenOfA+lenOfB));
 
    if (NULL == c)
    {
        return 0;
    }
 
    while ((i<lenOfA) && (j<lenOfB))
    {
        if (*(a+i) < *(b+j))
        {
            *(c+r) = *(a+i);
            i++;
        }
        else
        {
            *(c+r) = *(b+j);
            j++;
        }
        r++;
    }
     
    while (i < lenOfA)
    {
        *(c+r) = *(a+i);
        r++;
        i++;
    }
    while (j < lenOfB)
    {
        *(c+r) = *(b+j);
        r++;
        j++;
    }
 
    i = (lenOfA+lenOfB)%2;
    if (i)
    {
        return *(c+(lenOfA+lenOfB)/2);
    }
    else
    {
        return *(c+(lenOfA+lenOfB)/2-1);
    }
 
}
 
int main()
{
    long int *a = NULL;
    long int *b = NULL;
    int lenOfA = 0;
    int lenOfB = 0;
    int media = 0;
    int i = 0;
 
    while (EOF != scanf("%d", &lenOfA))
    {
        a = (long int *)malloc(sizeof(long int) * lenOfA);
        if (NULL == a)
        {
            return 0;
        }
        for(i = 0; i < lenOfA; i++)
        {
            scanf("%d", &a[i]);
        }
         
        scanf("%d", &lenOfB);
        b = (long int *)malloc(sizeof(long int) * lenOfB);
        if (NULL == b)
        {
            return 0;
        }
        for(i = 0; i < lenOfB; i++)
        {
            scanf("%d", &b[i]);
        }
 
        media = getMedia(a, lenOfA, b, lenOfB);
        printf("%d\n", media);
 
        free(a);
        a = NULL;
        free(b);
        b = NULL;
         
    }
    return 0;
}
/**************************************************************
    Problem: 1004
    User: ruoshui1314
    Language: C++
    Result: Accepted
    Time:0 ms
    Memory:1020 kb
****************************************************************/</span>


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值