hdu 4430 枚举+二分

Yukari's Birthday

Time Limit: 12000/6000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 3270    Accepted Submission(s): 697


Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
  
  
18 111 1111
 

Sample Output
  
  
1 17 2 10 3 10
 

Source
2012 Asia ChangChun Regional Contest

/*枚举r,然后用二分来求对应的k.
因为题目上k>=2,所以r肯定不会很大,二分就可以了。
需要注意的是二分时初始右边界不能太大,不然会导致计算过程超出long long*/
#include<stdio.h>
#include<math.h>
typedef __int64  ll;
ll fun(ll k,ll i,ll n)
{
  ll s=1,j,m;
   for(j=1;j<=i+1;j++)
   {
       s=s*k;
       if(((s-k)/(k-1)) >n)
        return 1;
   }
   m=(s-k)/(k-1);
   if(m==n)
     return 0;
   else if(m==n-1)
      return 0;
   else if(m<n)
      return -1;
   else if(m>n)
      return 1;
}
int main()
{
   ll n,l,r,ans,mid,i,k,x,y;
   while(scanf("%I64d",&n)!=EOF)
   {
      y=1; x=n-1;//是1的时候
      for(i=2;i<=40;i++)
      {
        l=2;r=(ll)pow(n,1.0/i);//求出右边界的最大值
        while(l<=r)
        {
           ll mid=(l+r)/2;
           //printf("mid=%lld ans=%lld\n",mid,ans);
           ans=fun(mid,i,n);
           if(ans==0)
            {
              if(mid*i<x*y)
              {
                x=mid;
                y=i;
              }
              break;
            }
            else if(ans<0)
               l=mid+1;
            else
               r=mid-1;
        }
      }
      printf("%I64d %I64d\n",y,x);
   }
   return 0;
}


 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值