2012长春站K题 || hdu4430 枚举+二分

http://acm.hdu.edu.cn/showproblem.php?pid=4430

Problem Description
Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time, though she herself insists that she is a 17-year-old girl.
To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place k i candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ i ≤ r. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.
 

Input
There are about 10,000 test cases. Process to the end of file.
Each test consists of only an integer 18 ≤ n ≤ 10 12.
 

Output
For each test case, output r and k.
 

Sample Input
  
  
18 111 1111
 

Sample Output
  
  
1 17 2 10 3 10

值得一提的是:在蛋糕的正中间应该有放与不放那一根蜡烛两种选择。

水题但很有技巧性。。。

解题思路:

                 因为题目中的K的值是大于等于2的也就是说我们的i最大也就是2^i>n,因此我们可以枚举i:2~45,然后二分查找k。

                 至于为什么不从1开始查找,因为如果令r=1,在二分查找k的时候我们不能确定使先搜到n还是先搜到n-1

#include <stdio.h>
#include <iostream>
#include <string.h>
#include <algorithm>
using namespace std;

typedef __int64 LL;

LL n;

LL judge(LL k,int r)
{
    LL sum=1,ans=0;
    for(int i=1;i<=r;i++)
    {
        if(n/sum<k)//保证后文的sum永远小于n,防止爆掉LL ☆
            return n+1;
        sum*=k;
        ans+=sum;
    }
    return ans;
}

LL er_fen(int i)
{
    LL l=2,r=n;
    while(l<=r)
    {
        LL mid=l+(r-l)/2;
        LL x=judge(mid,i);
        if(x==n-1||x==n)
            return mid;
        else if(x>n)
            r=mid-1;
        else
            l=mid+1;
    }
    return -1;
}

int main()
{
    while(~scanf("%I64d",&n))
    {
        LL a=1,b=n-1;
        for(int i=2;i<45;i++)
        {
            LL s=er_fen(i);
            if(s!=-1&&s*i<a*b)
                a=i,b=s;
        }
        printf("%I64d %I64d\n",a,b);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值