POJ 3294 Life Forms (后缀数组,求出现在不少于k个字符串的最长子串)

Life Forms
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 9865 Accepted: 2725

Description

You may have wondered why most extraterrestrial life forms resemble humans, differing by superficial traits such as height, colour, wrinkles, ears, eyebrows and the like. A few bear no human resemblance; these typically have geometric or amorphous shapes like cubes, oil slicks or clouds of dust.

The answer is given in the 146th episode of Star Trek - The Next Generation, titled The Chase. It turns out that in the vast majority of the quadrant's life forms ended up with a large fragment of common DNA.

Given the DNA sequences of several life forms represented as strings of letters, you are to find the longest substring that is shared by more than half of them.

Input

Standard input contains several test cases. Each test case begins with 1 ≤ n ≤ 100, the number of life forms. n lines follow; each contains a string of lower case letters representing the DNA sequence of a life form. Each DNA sequence contains at least one and not more than 1000 letters. A line containing 0 follows the last test case.

Output

For each test case, output the longest string or strings shared by more than half of the life forms. If there are many, output all of them in alphabetical order. If there is no solution with at least one letter, output "?". Leave an empty line between test cases.

Sample Input

3
abcdefg
bcdefgh
cdefghi
3
xxx
yyy
zzz
0

Sample Output

bcdefg
cdefgh

?

Source

Waterloo Local Contest, 2006.9.30

/*
 * poj 3294
 * 给出n个字符串,求出现在一半以上字符串的最长子串,按照字典序输出所有结果
 * 将n个字符串连接起来,中间用没有出现过的字符隔开,然后求后缀数组。
然后二分答案,进行分组,判断每组的后缀是否出现在不少于k个的原串中,
 */
#include<stdio.h>
#include<iostream>
#include<string.h>
#define N 101010
using namespace std;
int t1[N],t2[N],x[N],s[N],c[N],sa[N],height[N],rank[N],b[N];
int vis[105];//数组开小点,不然tle,无语。。。
char str[105][1005];
void build_sa(int *s,int n,int m)
{
    int *x=t1,*y=t2,i,k,p;
    for(i=0; i<m; i++) c[i]=0;
    for(i=0; i<n; i++) c[x[i]=s[i]]++;
    for(i=1; i<m; i++) c[i]+=c[i-1];
    for(i=n-1; i>=0; i--) sa[--c[x[i]]]=i;
    for(k=1; k<=n; k<<=1)
    {
        p=0;
        for(i=n-k; i<n; i++) y[p++]=i;
        for(i=0; i<n; i++) if(sa[i]>=k) y[p++]=sa[i]-k;
        for(i=0; i<m; i++) c[i]=0;
        for(i=0; i<n; i++) c[x[y[i]]]++;
        for(i=1; i<m; i++) c[i]+=c[i-1];
        for(i=n-1; i>=0; i--) sa[--c[x[y[i]]]]=y[i];
        swap(x,y);
        p=1;
        x[sa[0]]=0;
        for(i=1; i<n; i++)
            x[sa[i]]=y[sa[i-1]]==y[sa[i]]&&y[sa[i-1]+k]==y[sa[i]+k]?p-1:p++;
        if(p>=n)
            break;
        m=p;
    }
}
void getheight(int n)
{
    int i,k=0,j;
    for(i=0; i<=n; i++)
        rank[sa[i]]=i;
    for(i=0; i<n; i++)
    {
        if(k) k--;
        j=sa[rank[i]-1];
        while(s[i+k]==s[j+k])
            k++;
        height[rank[i]]=k;
    }
}
int check(int len,int m,int n)
{
   int i,ret,tmp;
   memset(vis,0,sizeof(vis));
   tmp=b[sa[1]]; ret=0;
   if(tmp!=-1&&!vis[tmp])
   {
      ret++;
      vis[tmp]=1;
   }
   for(i=2;i<=n;i++)
   {
      if(height[i]<len)
      {
        if(ret>=m)
        return 1;
       ret=0; tmp=b[sa[i]]; memset(vis,0,sizeof(vis));
        if(tmp!=-1&&!vis[tmp])
        {
          ret++;
          vis[tmp]=1;
        }
      }
      else
      {
         tmp=b[sa[i]];
         if(tmp!=-1&&!vis[tmp])
         {
            ret++;
            vis[tmp]=1;
         }
         if(ret>=m)  return 1;
      }
   }
   return 0;
}
void put(int len,int m,int n)
{
   int ret=0,tmp,i,j;
   tmp=b[sa[1]];memset(vis,0,sizeof(vis));
   if(tmp!=-1&&!vis[tmp])
   {
      ret++;
      vis[tmp]=1;
   }
   for(i=2;i<=n;i++)
   {
       if(height[i]<len)
       {
         if(ret>=m)
         {
           for(j=0;j<len;j++)
             printf("%c",s[sa[i-1]+j]);
            printf("\n");
         }
           ret=0; tmp=b[sa[i]];memset(vis,0,sizeof(vis));
           if(tmp!=-1&&!vis[tmp])
           {
             ret++;
             vis[tmp]=1;
           }
        }
        else
         {
            tmp=b[sa[i]];
            if(tmp!=-1&&!vis[tmp])
            {
              ret++;
              vis[tmp]=1;
            }
         }
   }
   if(ret>=m)
   {
    for(j=0;j<len;j++)
      printf("%c",s[sa[i-1]+j]);
    printf("\n");
   }
}
int main()
{
    int n,k,l,r,m,ans,i,j,flag=1;
    while(scanf("%d",&n),n!=0)
    {
      if(flag==1)
        flag=0;
     else  printf("\n");
      k=0;
       for(i=0;i<n;i++)
       {
          scanf("%s",str[i]);
          for(j=0;str[i][j]!='\0';j++)
            b[k]=i,s[k++]=str[i][j];
       b[k]=-1;
       s[k++]=i+130;
       }
       k--; s[k]=0;
       build_sa(s,k+1,300);
       getheight(k);
       l=0;r=1000; m=n/2+1; ans=-1;
       while(l<=r)
       {
         int mid=(l+r)>>1;
         if(check(mid,m,k))
         {
           ans=mid;
           l=mid+1;
         }
         else
           r=mid-1;
       }
       //printf("ans=%d\n",ans);
       if(ans<=0)
         printf("?\n");
       else
        put(ans,m,k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值