HDU - 5090 考思维,变成安顺序排的数列

Tom and Jerry are playing a game with tubes and pearls. The rule of the game is: 

1) Tom and Jerry come up together with a number K. 

2) Tom provides N tubes. Within each tube, there are several pearls. The number of pearls in each tube is at least 1 and at most N. 

3) Jerry puts some more pearls into each tube. The number of pearls put into each tube has to be either 0 or a positive multiple of K. After that Jerry organizes these tubes in the order that the first tube has exact one pearl, the 2nd tube has exact 2 pearls, …, the Nth tube has exact N pearls. 

4) If Jerry succeeds, he wins the game, otherwise Tom wins. 

Write a program to determine who wins the game according to a given N, K and initial number of pearls in each tube. If Tom wins the game, output “Tom”, otherwise, output “Jerry”.
Input
The first line contains an integer M (M<=500), then M games follow. For each game, the first line contains 2 integers, N and K (1 <= N <= 100, 1 <= K <= N), and the second line contains N integers presenting the number of pearls in each tube.
Output
For each game, output a line containing either “Tom” or “Jerry”.
Sample Input
2 
5 1 
1 2 3 4 5 
6 2 
1 2 3 4 5 5 
Sample Output
Jerry 
Tom 

题意是:给出n个数和一个整数K,那n个数每个只能加上k的正倍数或者不加,问能否使序列变成1~n的序列;


两种方法,都是一步一步往前推,不放过任何情况;

第一种:与桶排序,用桶计数,一步一步往前推;

#include<stdio.h>      
#include<string.h>
#include<algorithm>
using namespace std;          //像这样的题就是一步一步的推得,不然情况太多了 
int main()
{
	int i,j,k,t,n,tt;
	scanf("%d",&t);
	int vis[110];
	while(t--)
	{
		memset(vis,0,sizeof(vis)); // 用数组,与桶排序相似,桶计数; 
		scanf("%d%d",&n,&k);
		for(i=0;i<n;i++)
		{
			scanf("%d",&tt);
			vis[tt]++;
		}
		int flag=1;   
		for(i=1;i<=n;i++)
		{
			if(!vis[i])
			{
				flag = 0;
				break;
			}
			vis[i+k]+=(vis[i]-1); // -1 是只允许用一个,多的数一步一步往前推,不放过任何情况; 
		}
		if(flag)
			 printf("Jerry\n");
		else printf("Tom\n");
	}
	return 0;
}

第二种加的是a[i],标记a[i],也是一步一步往上加的

#include<stdio.h>      
#include<string.h>   
#include<algorithm>
using namespace std;
int main()      
{
	int i,j,k,t,n;
	scanf("%d",&t);
	int vis[210],a[110];
	while(t--)
	{
		scanf("%d%d",&n,&k);  
		for(i=0;i<n;i++)
			scanf("%d",&a[i]);
		memset(vis,0,sizeof(vis));
		for(i=0;i<n;i++)  //这个也是一步一步往上加,不放过任何情况,不过这次是用数组标记,加的是a[i]的值; 
		{
			while(1)
			{
				if(a[i]>n) break;
				if(!vis[a[i]])
				{
					vis[a[i]]=1;
					break;
				}
				a[i]+=k;
			}
		}
		sort(a,a+n);
		for(i=0;i<n;i++)
		{
			if(a[i]!=i+1)
				break;
		}
		if(i>=n) printf("Jerry\n");
		else printf("Tom\n");
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值