poj 2777 Count Color(线段树+染色问题)

题目链接:http://poj.org/problem?id=2777

Count Color
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 40402 Accepted: 12186

Description

Chosen Problem Solving and Program design as an optional course, you are required to solve all kinds of problems. Here, we get a new problem. 

There is a very long board with length L centimeter, L is a positive integer, so we can evenly divide the board into L segments, and they are labeled by 1, 2, ... L from left to right, each is 1 centimeter long. Now we have to color the board - one segment with only one color. We can do following two operations on the board: 

1. "C A B C" Color the board from segment A to segment B with color C. 
2. "P A B" Output the number of different colors painted between segment A and segment B (including). 

In our daily life, we have very few words to describe a color (red, green, blue, yellow…), so you may assume that the total number of different colors T is very small. To make it simple, we express the names of colors as color 1, color 2, ... color T. At the beginning, the board was painted in color 1. Now the rest of problem is left to your. 

Input

First line of input contains L (1 <= L <= 100000), T (1 <= T <= 30) and O (1 <= O <= 100000). Here O denotes the number of operations. Following O lines, each contains "C A B C" or "P A B" (here A, B, C are integers, and A may be larger than B) as an operation defined previously.

Output

Ouput results of the output operation in order, each line contains a number.

Sample Input

2 2 4
C 1 1 2
P 1 2
C 2 2 2
P 1 2

Sample Output

2
1

Source


题目大意:一个长度为L的区间,最多有T种颜色,并且有O种操作,接下去有o行。

一共就两种操作:1、C a b c:表示的是将【a,b】这个区间染成颜色c。 2、P a b :表示的是询问【a,b】这个区间有多少种颜色。

解题思路:这个题目需要注意的是不能一直更新到最下面,就更新到符合的区间即可,否则会超时。


详见代码。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <cmath>
#include <queue>

using namespace std;

struct node
{
    int l,r;
    int num;
} s[400010];

int vis[35];

void InitTree(int l,int r,int k)
{
    s[k].l=l;
    s[k].r=r;
    s[k].num=1;
    int mid=(l+r)/2;
    if (l==r)
        return ;
    InitTree(l,mid,2*k);
    InitTree(mid+1,r,2*k+1);
}

void UpdataTree(int l,int r,int c,int k)
{
    if(s[k].l==l&&s[k].r==r)
    {
        s[k].num=c;
        return;
    }
    if (s[k].num==c)
        return;
    if (s[k].num!=-1)//如果所查询的区间不是多种颜色
    {
        s[2*k].num=s[k].num;//更新区间的颜色
        s[2*k+1].num=s[k].num;
        s[k].num=-1;//-1表示该区间有多种颜色
    }
    int mid=(s[k].l+s[k].r)/2;
    if (l>mid)
        UpdataTree(l,r,c,2*k+1);
    else if (r<=mid)
        UpdataTree(l,r,c,2*k);
    else
    {
        UpdataTree(l,mid,c,2*k);
        UpdataTree(mid+1,r,c,2*k+1);
    }
}

void SearchTree(int l,int r,int k)
{
    if (s[k].num!=-1)
    {
        vis[s[k].num]=1;
        return;
    }
    int mid=(s[k].l+s[k].r)/2;
    if (r<=mid)
        SearchTree(l,r,2*k);
    else if (l>mid)
        SearchTree(l,r,2*k+1);
    else
    {
        SearchTree(l,mid,2*k);
        SearchTree(mid+1,r,2*k+1);
    }
}

int main()
{
    int l,t,o,ans;
    while (~scanf("%d%d%d",&l,&t,&o))
    {
        InitTree(1,l,1);
        while (o--)
        {
            char ch;
            int a,b,c;
            getchar();
            scanf("%c",&ch);
            if (ch=='C')
            {
                scanf("%d%d%d",&a,&b,&c);
                if (a>b)
                    swap(a,b);
                UpdataTree(a,b,c,1);
            }
            else
            {

                scanf("%d%d",&a,&b);
                if (a>b)
                    swap(a,b);
                memset(vis,0,sizeof(vis));
                SearchTree(a,b,1);
                ans=0;
                for (int i=1; i<=t; i++)
                    if (vis[i]==1)
                        ans++;
                printf ("%d\n",ans);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值