hdu 5748 Bellovin(BestCoder Round #84——最长递增子序列)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5748

Bellovin

Time Limit: 6000/3000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 929    Accepted Submission(s): 421


Problem Description
Peter has a sequence  a1,a2,...,an  and he define a function on the sequence --  F(a1,a2,...,an)=(f1,f2,...,fn) , where  fi  is the length of the longest increasing subsequence ending with  ai .

Peter would like to find another sequence  b1,b2,...,bn  in such a manner that  F(a1,a2,...,an)  equals to  F(b1,b2,...,bn) . Among all the possible sequences consisting of only positive integers, Peter wants the lexicographically smallest one.

The sequence  a1,a2,...,an  is lexicographically smaller than sequence  b1,b2,...,bn , if there is such number  i  from  1  to  n , that  ak=bk  for  1k<i  and  ai<bi .
 

Input
There are multiple test cases. The first line of input contains an integer  T , indicating the number of test cases. For each test case:

The first contains an integer  n   (1n100000)  -- the length of the sequence. The second line contains  n  integers  a1,a2,...,an   (1ai109) .
 

Output
For each test case, output  n  integers  b1,b2,...,bn   (1bi109)  denoting the lexicographically smallest sequence.
 

Sample Input
  
  
3 1 10 5 5 4 3 2 1 3 1 3 5
 

Sample Output
  
  
1 1 1 1 1 1 1 2 3
 

Source
 
题目大意:

Peter有一个序列a_1,a_2,...,a_na1,a2,...,an. 定义F(a_1,a_2,...,a_n)=(f_1,f_2,...,f_n)F(a1,a2,...,an)=(f1,f2,...,fn), 其中f_ifi是以a_iai结尾的最长上升子序列的长度.

Peter想要找到另一个序列b_1,b_2,...,b_nb1,b2,...,bn使得F(a_1,a_2,...,a_n)F(a1,a2,...,an)F(b_1,b_2,...,b_n)F(b1,b2,...,bn)相同. 对于所有可行的正整数序列, Peter想要那个字典序最小的序列.

序列a_1, a_2, ..., a_na1,a2,...,anb_1, b_2, ..., b_nb1,b2,...,bn字典序小, 当且仅当存在一个正整数ii (1 \le i \le n)(1in)满足对于所有的kk (1 \le k < i)(1k<i)都有a_k = b_kak=bk并且a_i < b_iai<bi.
解题思路:

定义一个l数组,初始化都为最大值。再循环输入的数。找到l数组中第一个比a大的数,记录下标即可。

详细过程如下图。


详见代码。

(第一种方法:通过二分的方法来找第一个比a大的数的下标值)

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define INF (1<<31-1)

int l[100010];

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,a;
        scanf("%d",&n);
        for(int i=0; i<=n; i++)
            l[i]=INF;
        for (int i=0; i<n; i++)
        {
            scanf("%d",&a);
            int j;
            int ll,r;
            ll=0,r=n;
            while(ll<=r)
            {

                int mid=(r+ll)/2;
                if (a<l[mid])
                    r=mid-1;
                else if (a>l[mid])
                    ll=mid+1;
                else
                {
                    ll=mid;
                    break;
                }

            }
            printf (i==0?"%d":" %d",ll+1);
            l[ll]=a;
        }
        printf("\n");
    }
    return 0;
}
第二种方法(通过库的函数实现)

#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

#define INF (1<<31-1)

int l[100010];

int main()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,a;
        scanf("%d",&n);
        for(int i=0; i<=n; i++)
            l[i]=INF;
        for (int i=0; i<n; i++)
        {
            scanf("%d",&a);
            int ll=lower_bound(l,l+n,a)-l;//得到l数组里第一个比a大的数
            printf (i==0?"%d":" %d",ll+1);
            l[ll]=a;
        }
        printf("\n");
    }
    return 0;
}









 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值