hdu 5795 A Simple Nim(2016 Multi-University Training Contest 6——博弈)

题目大意:http://acm.hdu.edu.cn/showproblem.php?pid=5795

A Simple Nim

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 550    Accepted Submission(s): 363


Problem Description
Two players take turns picking candies from n heaps,the player who picks the last one will win the game.On each turn they can pick any number of candies which come from the same heap(picking no candy is not allowed).To make the game more interesting,players can separate one heap into three smaller heaps(no empty heaps)instead of the picking operation.Please find out which player will win the game if each of them never make mistakes.
 

Input
Intput contains multiple test cases. The first line is an integer  1T100 , the number of test cases. Each case begins with an integer n, indicating the number of the heaps, the next line contains N integers  s[0],s[1],....,s[n1] , representing heaps with  s[0],s[1],...,s[n1]  objects respectively. (1n106,1s[i]109)
 

Output
For each test case,output a line whick contains either"First player wins."or"Second player wins".
 

Sample Input
  
  
2 2 4 4 3 1 2 4
 

Sample Output
  
  
Second player wins. First player wins.
 

Author
UESTC
 

Source
 
题目大意:
两人于最优策略对n堆物品进行抓取,不能抓取的人输。
1、从同一堆中取任意个(>=0)
2、把一堆分成任意三堆(每一堆至少有一个)

解题思路:

sg[0]=0

当x=8k+7时sg[x]=8k+8,

当x=8k+8时sg[x]=8k+7,

其余时候sg[x]=x;(k>=0)

打表找规律可得,数学归纳法可证。


先附上打表代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int sg[500];

int dfs(int n)
{
    if(sg[n]!=-1)
        return sg[n];
    int vis[500];
    memset(vis,0,sizeof(vis));
    for(int i=0; i<n; i++)
    {
        vis[dfs(i)]=1;
    }
    for(int i=1; i<n; i++)
    {
        for(int j=1; j+i<n; j++)
        {
            vis[dfs(i)^dfs(j)^dfs(n-i-j)]=1;
        }
    }
    int i;
    for(i=0; i<500; i++)
        if(vis[i]==0)
            break;
    return sg[n]=i;
}


int main ()
{
    memset(sg,-1,sizeof(sg));
    sg[0]=0;
    for(int i=1; i<=50; i++)
    {
        sg[i]=dfs(i);
        printf("%d:%d\n",i,sg[i]);
    }
    
    return 0;
}

AC代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

int main ()
{
    int t;
    scanf("%d",&t);
    while (t--)
    {
        int n,q;
        scanf("%d",&n);
        int ans=0;
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&q);
            if (q%8==0)
                ans^=(q-1);
            else if(q%8==7)
                ans^=(q+1);
            else
                ans^=q;
        }
        if(ans==0)
            printf ("Second player wins.\n");
        else
            printf ("First player wins.\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值