hdu 5813 Elegant Construction(2016 Multi-University Training Contest 7——暴力)

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5813

Elegant Construction

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 578    Accepted Submission(s): 295
Special Judge

Problem Description
Being an ACMer requires knowledge in many fields, because problems in this contest may use physics, biology, and even musicology as background. And now in this problem, you are being a city architect!
A city with N towns (numbered 1 through N) is under construction. You, the architect, are being responsible for designing how these towns are connected by one-way roads. Each road connects two towns, and passengers can travel through in one direction.

For business purpose, the connectivity between towns has some requirements. You are given N non-negative integers a1 .. aN. For 1 <= i <= N, passenger start from town i, should be able to reach exactly ai towns (directly or indirectly, not include i itself). To prevent confusion on the trip, every road should be different, and cycles (one can travel through several roads and back to the starting point) should not exist.

Your task is constructing such a city. Now it's your showtime!
 

Input
The first line is an integer T (T <= 10), indicating the number of test case. Each test case begins with an integer N (1 <= N <= 1000), indicating the number of towns. Then N numbers in a line, the ith number ai (0 <= ai < N) has been described above.
 

Output
For each test case, output "Case #X: Y" in a line (without quotes), where X is the case number starting from 1, and Y is "Yes" if you can construct successfully or "No" if it's impossible to reach the requirements.

If Y is "Yes", output an integer M in a line, indicating the number of roads. Then M lines follow, each line contains two integers u and v (1 <= u, v <= N), separated with one single space, indicating a road direct from town u to town v. If there are multiple possible solutions, print any of them.
 

Sample Input
  
  
3 3 2 1 0 2 1 1 4 3 1 1 0
 

Sample Output
  
  
Case #1: Yes 2 1 2 2 3 Case #2: No Case #3: Yes 4 1 2 1 3 2 4 3 4
 

Author
SYSU
 

Source
 
题目大意:给n个城市,告诉每个城市可以到达其他城市的个数,可以实现输出Yes在输出路径,否则输出NO。

特别注意:路径是单向的,并且路径不能有环。

解题思路:

将每个城市到达其他点的个数从大到小排序,在暴力,先要给点数最大的实现,找到比他小的点就接到他下面,直到接上的点数和他要求点数相同即可。


详见代码。

#include <iostream>
#include <cstdio>
#include <algorithm>

using namespace std;

#define N 1010

struct node
{
    int a,i;
} s[N];

struct node1
{
    int st,ed;
} path[N*N];

int n,k;//k表示一共建了几条路

bool cmp(node a,node b)
{
    if (a.a==b.a)
        return a.i<b.i;
    return a.a>b.a;
}

bool Build()
{
    k=0;
    int num;//num记录当前这个点;连了几条边

    for (int i=1; i<=n; i++)
    {
        num=0;
        for (int j=n; j>=1; j--)
        {
            if (s[i].a>s[j].a)
            {
                path[k].st=s[i].i;
                path[k].ed=s[j].i;
                k++;
                num++;
            }
            if (num==s[i].a)
            {
                break;
            }
        }
        if (num<s[i].a)
            return false;
    }
    return true;
}

int main()
{
    int t,Case=1;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&s[i].a);
            s[i].i=i;
        }
        sort(s+1,s+n+1,cmp);
        if (Build()==true)
        {
            printf ("Case #%d: Yes\n",Case++);
            printf ("%d\n",k);
            for (int i=0;i<k;i++)
            {
                printf ("%d %d\n",path[i].st,path[i].ed);
            }
        }
        else
        {
            printf ("Case #%d: No\n",Case++);
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值