poj1797 dijkstra变形

Heavy Transportation
Time Limit: 3000MS  Memory Limit: 30000K
Total Submissions: 12464  Accepted: 3298

Description

Background
Hugo Heavy is happy. After the breakdown of the Cargolifter project he can now expand business. But he needs a clever man who tells him whether there really is a way from the place his customer has build his giant steel crane to the place where it is needed on which all streets can carry the weight.
Fortunately he already has a plan of the city with all streets and bridges and all the allowed weights.Unfortunately he has no idea how to find the the maximum weight capacity in order to tell his customer how heavy the crane may become. But you surely know.

Problem
You are given the plan of the city, described by the streets (with weight limits) between the crossings, which are numbered from 1 to n. Your task is to find the maximum weight that can be transported from crossing 1 (Hugo's place) to crossing n (the customer's place). You may assume that there is at least one path. All streets can be travelled in both directions.
Input

The first line contains the number of scenarios (city plans). For each city the number n of street crossings (1 <= n <= 1000) and number m of streets are given on the first line. The following m lines contain triples of integers specifying start and end crossing of the street and the maximum allowed weight, which is positive and not larger than 1000000. There will be at most one street between each pair of crossings.
Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the maximum allowed weight that Hugo can transport to the customer. Terminate the output for the scenario with a blank line.
Sample Input

1
3 3
1 2 3
1 3 4
2 3 5

Sample Output

Scenario #1:
4

 

 

核心部分是:key[j]=max(key[j],min(key[tt],a[tt][j])); 其中key是由点1到达每个点的最大载重,tt是最近被发现的点,j是还没被发现的点,a[tt][j]是点tt与点j之间的边的载重。

#include <cstdlib>
#include <iostream>
#include<stdio.h>
#include<memory.h>
#include <string.h>
#include<algorithm>
using namespace std;
#define MaxN 1100
#define MaxInt 200000000
int map[MaxN][MaxN],dist[MaxN];
bool mark[MaxN];
int n,m;
int main()
{int min1,minj,temp;
 int a,b,c;

int count=1;
int t;
scanf("%d",&t);
while(t--)
{
scanf("%d%d",&n,&m);

/*for(int i=1;i<=n;i++)
for(int j=1;j<=n;j++)
map[i][j]=map[j][i]= MaxInt;*/
memset(map,0,sizeof(map));

for(int i=0;i<m;i++)
{
    int a,b,q;
    scanf("%d%d%d",&a,&b,&q);
    map[a][b]=map[b][a]=q;
}

 

//初始化
for (int i=1;i<=n;i++)
dist[i]=MaxInt;//

memset(mark,0,sizeof(mark));
//dist[1]=0; //把起点并入集合,搜索时就可以从起点寻找到第一条最短的边了
for(int i=1;i<=n;i++)
{
    //if(map[1][i]!=0)
    dist[i]=map[1][i];
    //else
    //dist[i]=MaxInt;
}

mark[1]=true;
for (int i=1;i<=n-1;i++)//
{min1=0;
for (int j=1;j<=n;j++) //查找到原集合的最短的边
{if (!mark[j]&&dist[j]>min1)
{min1=dist[j];
 minj=j;
}}
mark[minj]=1;
for (int j=1;j<=n;j++) //每并入一个点都要对原来的边进行修正,保证任意时刻源点到目标点的距//离都是最短的。
{if (!mark[j]&&map[minj][j]>dist[j]&&dist[minj]>dist[j])

dist[j]=map[minj][j]<dist[minj]?map[minj][j]:dist[minj];

}}
printf("Scenario #%d:\n",count++);
printf("%d\n\n",dist[n]);}
system("pause");
return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值