hdu2873 Bomb Game-----sg

Bomb Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 353    Accepted Submission(s): 165


Problem Description
John and Jack, two mathematicians, created a game called “Bomb Game” at spared time. This game is played on an n*m chessboard. A pair of integers (p, q) represents the grid at row p, column q. Some bombs were placed on the chessboard at the beginning. Every round, a player can choose to explode a bomb located at (p, q), and the exploded bomb will disappear. Furthermore:

1.If p>1 and q>1, the bomb will split up into two bombs located at (u, q) and (p, v), u<p, v<q, u and v are chosen by the player.
2.If p=1 and q>1, one new bomb will be produced, located at (p, v), v<q, v can be chosen freely by the player.
3.If q=1 and p>1, one new bomb will be produced, located at (u, q), u<p, u can be chosen freely by the player.


If two bombs located at the same position or a bomb located at (1, 1), they will be exploded automatically without producing new bombs.
Two players play in turn, until one player cannot explode the bombs and loses the game.
John always plays first.
Now, we’ll give you an initial situation, and you should tell us who will win at last. Assume John and Jack are smart enough, and they always do the best choice.

Input
There are several test cases, each one begins with two integers n and m, 0<n, m<=50, represents the number of rows and columns. Following by an n*m grid, describing the initial situation, ‘#’ indicates bomb.
The input is terminated by n=m=0.

Output
For each test case, output one line, the name of the winner.

Sample Input
  
  
2 2 .# .. 2 2 .# .# 0 0

Sample Output
  
  
John Jack

Source

Recommend
gaojie
 
这题A的我好辛苦,题目所说的1是我们输入的矩阵的0,即(1,1)这个位置是我们输入的矩阵的(0,0)位置,晕死,我直接想死了。
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<memory.h>
using namespace std;
int sg[60][60];
char str[60][60];
int num[600];
int dfs(int x,int y)
{
    memset(num,-1,sizeof(num));
    for(int i=0;i<x;i++)
    for(int j=0;j<y;j++)
    {
        num[sg[i][y]^sg[x][j]]=1;
    }
    for(int i=0;;i++)
    if(num[i]==-1) return i;
}
int main()
{
    for(int i=0;i<=50;i++)
    sg[0][i]=sg[i][0]=i;
    for(int i=1;i<=50;i++)
    for(int j=1;j<=50;j++)
    sg[i][j]=dfs(i,j);
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        int ans=0;
        for(int i=0;i<n;i++)
        {
            scanf("%s",str[i]);
            for(int j=0;j<m;j++)
            {
                if(str[i][j]=='#')
                {
                    ans^=sg[i][j];
                }
            }
        }
        if(ans) puts("John");
        else puts("Jack");
    }
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值