hdu2873 Bomb Game

67 篇文章 1 订阅

Bomb Game

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 440 Accepted Submission(s): 206


Problem Description
John and Jack, two mathematicians, created a game called “Bomb Game” at spared time. This game is played on an n*m chessboard. A pair of integers (p, q) represents the grid at row p, column q. Some bombs were placed on the chessboard at the beginning. Every round, a player can choose to explode a bomb located at (p, q), and the exploded bomb will disappear. Furthermore:

1.If p>1 and q>1, the bomb will split up into two bombs located at (u, q) and (p, v), u<p, v<q, u and v are chosen by the player.
2.If p=1 and q>1, one new bomb will be produced, located at (p, v), v<q, v can be chosen freely by the player.
3.If q=1 and p>1, one new bomb will be produced, located at (u, q), u<p, u can be chosen freely by the player.


If two bombs located at the same position or a bomb located at (1, 1), they will be exploded automatically without producing new bombs.
Two players play in turn, until one player cannot explode the bombs and loses the game.
John always plays first.
Now, we’ll give you an initial situation, and you should tell us who will win at last. Assume John and Jack are smart enough, and they always do the best choice.

Input
There are several test cases, each one begins with two integers n and m, 0<n, m<=50, represents the number of rows and columns. Following by an n*m grid, describing the initial situation, ‘#’ indicates bomb.
The input is terminated by n=m=0.

Output
For each test case, output one line, the name of the winner.

Sample Input
  
  
2 2 .# .. 2 2 .# .# 0 0

Sample Output
  
  
John Jack
可以直接根据sg 函数,直接打表求出sg的值 ,这样就可以转化成一般的nim游戏了!

sg函数的定义:

首先定义mex(minimal excludant)运算,这是施加于一个集合的运算,表示最小的不属于这个集合的非负整数。例如mex{0,1,2,4}=3、mex{2,3,5}=0、mex{}=0。

对于一个给定的有向无环图,定义关于图的每个顶点的SG函数如下:sg(x)=mex{ sg(y) | y是x的后继 },即一个节点的sg函数值等于其所有后继结点的sg函数值集合的mex

#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
#define M 55
int pri[M][M],map[10000];
int getsg(int a,int b){
    int i,j;
    mem(map,0);
    for(i=0;i<a;i++)
        for(j=0;j<b;j++){
            map[pri[a][j]^pri[i][b]]=1;
        }
    for(i=0;;i++){
        if(!map[i])
        return i;
    }
}
int main()
{
    int n,m,ans,i,j;char c;
    mem(pri,-1);
    for(i=0;i<M;i++)
    pri[0][i]=pri[i][0]=i;
    for(i=1;i<M;i++)
        for(j=1;j<M;j++){
            pri[i][j]=getsg(i,j);
        }
    while(scanf("%d%d",&n,&m)!=EOF&&n+m){
        getchar();
        for(ans=0,i=0;i<n;i++){
            for(j=0;j<m;j++){
                c=getchar();
                if(c=='#'){
                    ans^=pri[i][j];
                }
            }
            getchar();
        }
        if(ans)printf("John\n");
        else printf("Jack\n");
    }
    return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值