hdu4405 Aeroplane chess---金华网络赛 期望

Aeroplane chess

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 24    Accepted Submission(s): 20


Problem Description
Hzz loves aeroplane chess very much. The chess map contains N+1 grids labeled from 0 to N. Hzz starts at grid 0. For each step he throws a dice(a dice have six faces with equal probability to face up and the numbers on the faces are 1,2,3,4,5,6). When Hzz is at grid i and the dice number is x, he will moves to grid i+x. Hzz finishes the game when i+x is equal to or greater than N.

There are also M flight lines on the chess map. The i-th flight line can help Hzz fly from grid Xi to Yi (0<Xi<Yi<=N) without throwing the dice. If there is another flight line from Yi, Hzz can take the flight line continuously. It is granted that there is no two or more flight lines start from the same grid.

Please help Hzz calculate the expected dice throwing times to finish the game.

Input
There are multiple test cases.
Each test case contains several lines.
The first line contains two integers N(1≤N≤100000) and M(0≤M≤1000).
Then M lines follow, each line contains two integers Xi,Yi(1≤Xi<Yi≤N). 
The input end with N=0, M=0.

Output
For each test case in the input, you should output a line indicating the expected dice throwing times. Output should be rounded to 4 digits after decimal point.

Sample Input
  
  
2 0 8 3 2 4 4 5 7 8 0 0

Sample Output
  
  
1.1667 2.3441

Source

Recommend
zhoujiaqi2010
比赛的时候看了下这里,现学现卖的~ http://kicd.blog.163.com/blog/static/126961911200910168335852/
n个方程,回带一下就行。e[n]=0,所有标号i大于n的期望值e[i]也为0.
好像有人没看懂,我写个例子。
比如n=3,m=0
所列方程为e[0]=1/6e[1]+1/6e[2]+1/6e[3]+1
                  e[1]=1/6e[2]+1/6e[3]+1
                  e[2]=1/6e[3]+1
                  e[3]=0
从0这个点可以到1,2,3,4,5,6这几个位置,由于大于等于3游戏结束,不会再有期望的投色子次数了,所以跳到3和大于3的格子里期望值也就都是0了。
所以我们列出n个方程后直接回带就能把e[0]求出来。如e[3]=0可以求出e[2]=1,已知了e[2]和e[3]就可以求出e[1],进而求出e[0].
两层for循环就是一个回带的过程。
题目还有可以直接从a跳到b,不需要投色子的,那样就直接标记一下,a的期望值也就等于b的期望值。(a<b)
#include<iostream>
#include<cstdlib>
#include<stdio.h>
#include<string.h>
#include<map>
#include<memory.h>
#define ll __int64
using namespace std;
double e[100010];
int f[100010];
int main()
{
    int n,m;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        if(n==0&&m==0) break;
        for(int i=0;i<=n;i++) e[i]=0;
        memset(f,-1,sizeof(f));
        for(int i=0;i<m;i++)
        {
            int a,b;
            scanf("%d%d",&a,&b);
            f[a]=b;
        }
        e[n]=0;
        for(int i=n-1;i>=0;i--)
        {
            if(f[i]!=-1) e[i]=e[f[i]];
            else
            {
                for(int j=1;j<=6;j++)
                {
                    if(i+j<=n)
                    e[i]+=(1.0/6)*e[i+j];
                    else break;
                }
                e[i]+=1.0;
            }
        }
        printf("%.4lf\n",e[0]);

    }
}

  • 5
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 2
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 2
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值