堆的应用和几个例题

Xiao Ming and Xiao Bao are playing a simple Numbers game. In a round Xiao Ming can choose to write down a number, or ask Xiao Bao what the kth great number is. Because the number written by Xiao Ming is too much, Xiao Bao is feeling giddy. Now, try to help Xiao Bao.

Input

There are several test cases. For each test case, the first line of input contains two positive integer n, k. Then n lines follow. If Xiao Ming choose to write down a number, there will be an " I" followed by a number that Xiao Ming will write down. If Xiao Ming choose to ask Xiao Bao, there will be a "Q", then you need to output the kth great number.

Output

The output consists of one integer representing the largest number of islands that all lie on one line.

Sample Input

8 3
I 1
I 2
I 3
Q
I 5
Q
I 4
Q

Sample Output

1
2
3

Hint
Xiao  Ming  won't  ask  Xiao  Bao  the  kth  great  number  when  the  number  of  the  written number is smaller than k. (1=<k<=n<=1000000).
        
 题意:输入n,k,接下来n种操作,当输入为Q时,找到此时第K大的数。

解析:建立一个最小堆,然后只保存K个数,当大于K个数的时候,如果此时这个数比堆顶元素小,那么就不进去;否则pop掉堆顶元素,该数进堆。

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<vector>
using namespace std;
int a[10005];
int main()
{
    int n,k;
    while(~scanf("%d %d",&n,&k))
    {
        priority_queue<int,vector<int>,greater<int> >q;
        int cnt = 0;
        while(n--)
    {
        getchar();
        char ch;
        scanf("%c",&ch);
        if(ch=='I')
        {
           int num;
           scanf("%d",&num);
           if(cnt<k)
                q.push(num);
           else
           {
               if(num>q.top())
               {
                   q.pop();
                   q.push(num);
               }
           }
           cnt ++;
        }
        else
            printf("%d\n",q.top());
    }
    }

}

浙江桐乡乌镇共有n个人,请找出该镇上的前m个大富翁.

Input

输入包含多组测试用例.
每个用例首先包含2个整数n(0<n<=100000)和m(0<m<=10),其中: n为镇上的人数,m为需要找出的大富翁数, 接下来一行输入镇上n个人的财富值.
n和m同时为0时表示输入结束.

Output

请输出乌镇前m个大富翁的财产数,财产多的排前面,如果大富翁不足m个,则全部输出,每组输出占一行.

Sample Input

3 1
2 5 -1
5 3
1 2 3 4 5
0 0

Sample Output

5
5 4 3

解析:建立一个最大堆,如果最大堆里元素的数量大于等于要求的m,那么就输出m个。

否则输出n个。

#include<iostream>
#include<algorithm>
#include<queue>
#include<cstdio>
#include<vector>
using namespace std;
#define maxn 100005
int a[maxn];
int main()
{
    int n,m;
    while(~scanf("%d %d",&n,&m)&&n&&m)
    {
        priority_queue<int/*,vector<int>,greater<int> */>q;
        for(int i = 0; i < n; i ++)
        {
            int x;
            scanf("%d",&x);
            q.push(x);
        }
        if(q.size()>=m)
        {
            while(!q.empty())
            {
                if(m==1)
                {
                    printf("%d",q.top());
                    break;
                }
                else
                {
                    printf("%d ",q.top());
                    q.pop();
                    m--;
                }
            }
        }
        else
        {
            while(!q.empty())
            {
                if(q.size()==1)
                {
                    printf("%d",q.top());
                    break;
                }
                else
                {
                    printf("%d ",q.top());
                    q.pop();
                }
            }
        }
        printf("\n");
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值