快速幂及几个应用

快速幂:快速求a^b

核心代码:

int q_pow(int a,int b)
{
    int res = 1;
    while(b)
    {
        if(b&1)//如果b是奇数,那么就乘一下底数
            res *= a;
        a = a*a;
        b>>=1;
    }
    return res;
}

可以根据需求加上MOD或者将数据类型改为long long  int

POJ 1995-Raising Modulo Numbers

People are different. Some secretly read magazines full of interesting girls' pictures, others create an A-bomb in their cellar, others like using Windows, and some like difficult mathematical games. Latest marketing research shows, that this market segment was so far underestimated and that there is lack of such games. This kind of game was thus included into the KOKODáKH. The rules follow:

Each player chooses two numbers Ai and Bi and writes them on a slip of paper. Others cannot see the numbers. In a given moment all players show their numbers to the others. The goal is to determine the sum of all expressions Ai Bi from all players including oneself and determine the remainder after division by a given number M. The winner is the one who first determines the correct result. According to the players' experience it is possible to increase the difficulty by choosing higher numbers.

You should write a program that calculates the result and is able to find out who won the game.
 

Input

The input consists of Z assignments. The number of them is given by the single positive integer Z appearing on the first line of input. Then the assignements follow. Each assignement begins with line containing an integer M (1 <= M <= 45000). The sum will be divided by this number. Next line contains number of players H (1 <= H <= 45000). Next exactly H lines follow. On each line, there are exactly two numbers Ai and Bi separated by space. Both numbers cannot be equal zero at the same time.

Output

For each assingnement there is the only one line of output. On this line, there is a number, the result of expression

(A1B1+A2B2+ ... +AHBH)mod M.

Sample Input

3
16
4
2 3
3 4
4 5
5 6
36123
1
2374859 3029382
17
1
3 18132

Sample Output

2
13195
13

题意:输入第一行代表样例个数,第二行代表底数的个数,计算(a[0]^b[0] + a[1]^b[1] + ..... + a[n]^b[n])% MOD

解析:利用快速幂

#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<string>
#include<set>
#include<sstream>
#include<queue>
#include<cstdio>
#include<stack>
#include<cmath>
using namespace std;
long long int q_power(long long int a,long long int b,long long int mod)
{
	long long int res = 1;
	while(b)
	{
		if(b&1)
			res = (res*a)%mod;
		a = (a*a)%mod;
		b>>=1;
	}
	return res;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		long long int mod;
		int k;
		scanf("%lld %d",&mod,&k);
		long long int res = 0;
		for(int i = 0; i < k; i ++)
		{
			long long int a,b;
			scanf("%lld %lld",&a,&b);
			res += q_power(a,b,mod);
		}
		res = res%mod;
		printf("%lld\n",res);
	}
}

A Math Problem

You are given a positive integer n, please count how many positive integers k satisfy kk≤n

.Input

There are no more than 50 test cases.

Each case only contains a positivse integer n in a line.

1≤n≤1018

 

Output

For each test case, output an integer indicates the number of positive integers k satisfy kk≤n

in a line.

Sample Input

1
4

Sample Output

1
2

题意:计算到从k=1开始到k^k>n有几个k

解析:当K=16的时候就超过了范围,所以枚举从1-15的k,计算有几个K符合条件

#include<iostream>
#include<cstring>
#include<algorithm>
#include<map>
#include<string>
#include<set>
#include<sstream>
#include<queue>
#include<cstdio>
#include<stack>
#include<cmath>
using namespace std;
long long int q_power(long long int a,long long int b)
{
	long long int res = 1;
	while(b)
	{
		if(b&1)
			res = (res*a);
		a = (a*a);
		b>>=1;
	}
	return res;
}
int main()
{
	long long int n;
	while(~scanf("%lld",&n)&&n)
	{
		long long int counts = 0;
		for(long long int i = 1; i <= 15; i ++)
		{
		
			if(q_power(i,i)<=n)
				counts++;
			else
				break;
		}
		printf("%lld\n",counts);
	}
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值