This Gradle plugin requires a newer IDE able to request IDE model level 3

在AndroidStudio2.3.3版本下新导入了一个项目,总是报一个错:

This Gradle plugin requires a newer IDE able to request IDE model level 3.For Android Studio this means version 3.0+。


一开始一直以为是gradle版本不一致导致的问题,一直在改gradle的版本,下载不同版本的gradle,问题一直解决不了。后来好好

分析报的错误,才发现,已经很明确的告诉了错误的原因,

这个Gradle插件需要一个更新的IDE来请求IDE模型级别3。对于Android Studio来说,这意味着版本3.0 +

当前的gradle插件需要一个级别在3及以上的更新的IDE(即AndroidStudio)版本,也就是说当前版本的AndroidStudio不能满足这个项目

的要求,需要更新AndroidStudio在3.0+。所以更新一下AndroidStudio的版本就行了。

发布了60 篇原创文章 · 获赞 15 · 访问量 8万+
展开阅读全文

没有更多推荐了,返回首页

©️2019 CSDN 皮肤主题: 编程工作室 设计师: CSDN官方博客

分享到微信朋友圈

×

扫一扫,手机浏览