POJ 3009 深搜


D - Curling 2.0
Time Limit:1000MS    Memory Limit:65536KB    64bit IO Format:%I64d & %I64u

Description

On Planet MM-21, after their Olympic games this year, curling is getting popular. But the rules are somewhat different from ours. The game is played on an ice game board on which a square mesh is marked. They use only a single stone. The purpose of the game is to lead the stone from the start to the goal with the minimum number of moves.

Fig. 1 shows an example of a game board. Some squares may be occupied with blocks. There are two special squares namely the start and the goal, which are not occupied with blocks. (These two squares are distinct.) Once the stone begins to move, it will proceed until it hits a block. In order to bring the stone to the goal, you may have to stop the stone by hitting it against a block, and throw again.


Fig. 1: Example of board (S: start, G: goal)

The movement of the stone obeys the following rules:

  • At the beginning, the stone stands still at the start square.
  • The movements of the stone are restricted to x and y directions. Diagonal moves are prohibited.
  • When the stone stands still, you can make it moving by throwing it. You may throw it to any direction unless it is blocked immediately(Fig. 2(a)).
  • Once thrown, the stone keeps moving to the same direction until one of the following occurs:
    • The stone hits a block (Fig. 2(b), (c)).
      • The stone stops at the square next to the block it hit.
      • The block disappears.
    • The stone gets out of the board.
      • The game ends in failure.
    • The stone reaches the goal square.
      • The stone stops there and the game ends in success.
  • You cannot throw the stone more than 10 times in a game. If the stone does not reach the goal in 10 moves, the game ends in failure.


Fig. 2: Stone movements

Under the rules, we would like to know whether the stone at the start can reach the goal and, if yes, the minimum number of moves required.

With the initial configuration shown in Fig. 1, 4 moves are required to bring the stone from the start to the goal. The route is shown in Fig. 3(a). Notice when the stone reaches the goal, the board configuration has changed as in Fig. 3(b).


Fig. 3: The solution for Fig. D-1 and the final board configuration

Input

The input is a sequence of datasets. The end of the input is indicated by a line containing two zeros separated by a space. The number of datasets never exceeds 100.

Each dataset is formatted as follows.

the width(=w) and the height(=h) of the board
First row of the board

...
h-th row of the board

The width and the height of the board satisfy: 2 <= w <= 20, 1 <= h <= 20.

Each line consists of w decimal numbers delimited by a space. The number describes the status of the corresponding square.

0vacant square
1block
2start position
3goal position

The dataset for Fig. D-1 is as follows:

6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1

Output

For each dataset, print a line having a decimal integer indicating the minimum number of moves along a route from the start to the goal. If there are no such routes, print -1 instead. Each line should not have any character other than this number.

Sample Input

2 1
3 2
6 6
1 0 0 2 1 0
1 1 0 0 0 0
0 0 0 0 0 3
0 0 0 0 0 0
1 0 0 0 0 1
0 1 1 1 1 1
6 1
1 1 2 1 1 3
6 1
1 0 2 1 1 3
12 1
2 0 1 1 1 1 1 1 1 1 1 3
13 1
2 0 1 1 1 1 1 1 1 1 1 1 3
0 0

Sample Output

1
4
-1
4
10
-1
题意:给定一个由0,1,2,3 组成的矩阵,0 表示p平地,可以走通,1表示障碍物,不可走,2 表示移动物,可以击碎障碍物并停留在障碍物之前,3是出口,题意要求让你判断找到在有限的步骤(10步)内到达出口;
思路:主要分为两步1.移动到障碍物之前,超出界就说明这个方向不能走2.如何进行下个点的搜索
AC代码:
#include<iostream>
#include<cstdio>
using namespace std;
int w,h;
int sx,sy;
int ex,ey;
int sum;
int gra[21][21];
int xx[]={0,0,1,-1};
int yy[]={1,-1,0,0};
int isok(int x,int y){
    if(x>=0&&x<h&&y>=0&&y<w){
        return 1;
    }
    return 0;
}//越界函数的判断
void dfs(int tol,int x,int y){
    int i;
    if(tol>=10){
        return;
    }//走的步数大于10 直接返回
    for(i=0;i<4;i++){//四个方向
        int a=x+xx[i],b=y+yy[i];
        if((gra[a][b]==0)||(gra[a][b]==3)){
            while(gra[a][b]==0){//移动到障碍物之前的方法
                a+=xx[i];
                b+=yy[i];
            }
            if(isok(a,b)){//没有越界
                if(gra[a][b]==3){
                    if(tol+1<sum){
                        sum=tol+1;
                    }
                }//正好到达目标处
                if(gra[a][b]==1){
                    gra[a][b]=0;
                    dfs(tol+1,a-xx[i],b-yy[i]);
                    gra[a][b]=1;
                }
            }
        }
    }
}
int main(){
    while(~scanf("%d%d",&w,&h)&&w&&h){
            sum=11;
        for(int i=0;i<h;i++){
            for(int j=0;j<w;j++){
                scanf("%d",&gra[i][j]);
                if(gra[i][j]==2){
                    gra[i][j]=0;
                    sx=i;
                    sy=j;
                }
                if(gra[i][j]==3){
                    ex=i;
                    ex=j;
                }
            }
        }
        dfs(0,sx,sy);
        if(sum==11){
            printf("-1\n");
        }
        else{
            printf("%d\n",sum);
        }
    }
    return 0;
}
注意:之前想到用if来移动,相当麻烦,还是要多想想,不能急的敲代码,多做做题。。。。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值