hdu-多校-Time Zone

                                     Time Zone

 

Problem Description

Chiaki often participates in international competitive programming contests. The time zone becomes a big problem.
Given a time in Beijing time (UTC +8), Chiaki would like to know the time in another time zone s .

 

 

Input

There are multiple test cases. The first line of input contains an integer T (1≤T≤106 ), indicating the number of test cases. For each test case:
The first line contains two integers a , b (0≤a≤23,0≤b≤59 ) and a string s in the format of "UTC+X'', "UTC-X'', "UTC+X.Y'', or "UTC-X.Y'' (0≤X,X.Y≤14,0≤Y≤9 ).

 

 

Output

For each test, output the time in the format of hh:mm (24-hour clock).

 

 

Sample Input

 

3 11 11 UTC+8 11 12 UTC+9 11 23 UTC+0

 

 

Sample Output

 

11:11 12:12 03:23

 

 

#include<cstdio>
int main(){
	int t,h,m,mm,hh;
	char a[10];
	scanf("%d",&t);
	while(t--){
		a[6] = '0';
		a[7] = '0';
		double k;
		scanf("%d%d%s",&h,&m,a);
		//sscanf(a+4,"%lf",&k);  提取出数字k 
		if(a[5]-'0'>=0&&a[5]-'0'<=9) {
			hh = (a[4]-'0')*10+(a[5]-'0');
			mm = (a[7]-'0');
		}else{
			hh = a[4]-'0';
			mm = a[6]-'0';
		}
		h -= 8;
		if(h < 0) h += 24;
		if(a[3]=='+'){
			m += mm*6;
			if(m>=60){m = m-60;h++;}
			h+=hh;
			if(h>=24) h = h-24;
		}else{
			m-=mm*6;
			if(m<0) {m = 60+m;h--;}
			h-=hh;
			if(h<0) h = 24+h;
		}
		if(h < 10&&m>=10) printf("0%d:%d\n",h,m);
		else if(h >=10&&m<10) printf("%d:0%d\n",h,m);
		else if(h < 10&&m<10) printf("0%d:0%d\n",h,m);
		else printf("%d:%d\n",h,m);
	}	
	return 0;
}

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值