PTA L2-006 树的遍历

                                       L2-006 树的遍历 (25 分)

给定一棵二叉树的后序遍历和中序遍历,请你输出其层序遍历的序列。这里假设键值都是互不相等的正整数。

输入格式:

输入第一行给出一个正整数N(≤30),是二叉树中结点的个数。第二行给出其后序遍历序列。第三行给出其中序遍历序列。数字间以空格分隔。

输出格式:

在一行中输出该树的层序遍历的序列。数字间以1个空格分隔,行首尾不得有多余空格。

输入样例:

7
2 3 1 5 7 6 4
1 2 3 4 5 6 7

输出样例:

4 1 6 3 5 7 2

 最近在狂补数据结构,大一数据结构落下了太多

AC Code: 

#include <iostream>
#include <cstdio>
#include <queue>
#include <cstring>
#include <set>
#include <algorithm>
#include <cmath>
#include <map>
#include <ctime>
#include <cstdint>
#include <string>
#include <stack>
#include <vector>
using namespace std;
static const int MAX_N = 1e4 + 5;
typedef long long ll;
int in[35], post[35];
int lchild[35], rchild[35];
int buildTree(int L1, int R1, int L2, int R2) {
	if (L1 > R1) return 0;
	int rt = post[R1];
	int i = L2;
	while (in[i] != rt) ++i;	//匹配根节点
	lchild[rt] = buildTree(L1, R1 - R2 + i - 1, L2, i - 1);
	rchild[rt] = buildTree(R1 - R2 + i, R1 - 1, i + 1, R2);
	return rt;
}
void bfs(int rt) {
	queue<int>q;
	q.push(rt);
	while (!q.empty()) {
		int p = q.front();
		q.pop();
		if (p == rt) printf("%d", p);
		else printf(" %d", p);
		if (lchild[p]) q.push(lchild[p]);
		if (rchild[p]) q.push(rchild[p]);
	}
	putchar('\n');
}
int main() {
	int n;
	scanf("%d", &n);
	for (int i = 0; i < n; ++i) scanf("%d", &post[i]);
	for (int i = 0; i < n; ++i) scanf("%d", &in[i]);
	int root = buildTree(0, n - 1, 0, n - 1);
	bfs(root);
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值