POJ 3667 Hotel (线段树区间合并)

                                                     Hotel

The cows are journeying north to Thunder Bay in Canada to gain cultural enrichment and enjoy a vacation on the sunny shores of Lake Superior. Bessie, ever the competent travel agent, has named the Bullmoose Hotel on famed Cumberland Street as their vacation residence. This immense hotel has N (1 ≤ N ≤ 50,000) rooms all located on the same side of an extremely long hallway (all the better to see the lake, of course).

The cows and other visitors arrive in groups of size Di (1 ≤ Di ≤ N) and approach the front desk to check in. Each group i requests a set of Di contiguous rooms from Canmuu, the moose staffing the counter. He assigns them some set of consecutive room numbers r..r+Di-1 if they are available or, if no contiguous set of rooms is available, politely suggests alternate lodging. Canmuu always chooses the value of r to be the smallest possible.

Visitors also depart the hotel from groups of contiguous rooms. Checkout i has the parameters Xi and Di which specify the vacating of rooms Xi ..Xi +Di-1 (1 ≤ Xi ≤ N-Di+1). Some (or all) of those rooms might be empty before the checkout.

Your job is to assist Canmuu by processing M (1 ≤ M < 50,000) checkin/checkout requests. The hotel is initially unoccupied.

Input

* Line 1: Two space-separated integers: N and M
* Lines 2..M+1: Line i+1 contains request expressed as one of two possible formats: (a) Two space separated integers representing a check-in request: 1 and Di (b) Three space-separated integers representing a check-out: 2, Xi, and Di

Output

* Lines 1.....: For each check-in request, output a single line with a single integer r, the first room in the contiguous sequence of rooms to be occupied. If the request cannot be satisfied, output 0.

Sample Input

10 6
1 3
1 3
1 3
1 3
2 5 5
1 6

Sample Output

1
4
7
0
5

线段树区间合并,满足条件左端点查询

#include <iostream>
#include <queue>
#include <stack>
#include <cstdio>
#include <string>
#include <cstring>
#include <cmath>
#include <vector>
#include <algorithm>
#include <map>
#include <set>
#define Mod 1000000007
#define INF 0x3f3f3f3f
#define lson l, m, rt << 1
#define rson m + 1, r, rt << 1 | 1
#define eps 1e-8
typedef long long ll;
using namespace std;
static const int MAX_N = 5e4 + 5;
const double pi = acos(-1);
int lsum[MAX_N << 2], rsum[MAX_N << 2], msum[MAX_N << 2];
int cover[MAX_N << 2];

void pushDown(int rt, int m) {
	if (cover[rt] != -1) {
		cover[rt << 1] = cover[rt << 1 | 1] = cover[rt];
		msum[rt << 1] = lsum[rt << 1] = rsum[rt << 1] = cover[rt] ? 0 : m - (m >> 1);
		msum[rt << 1 | 1] = lsum[rt << 1 | 1] = rsum[rt << 1 | 1] = cover[rt] ? 0 : (m >> 1);
		cover[rt] = -1;
	}
}
void pushUp(int rt, int m) {
	lsum[rt] = lsum[rt << 1];
	rsum[rt] = rsum[rt << 1 | 1];
	if (lsum[rt] == m - (m >> 1)) {
		lsum[rt] += lsum[rt << 1 | 1];
	}
	if (rsum[rt] == (m >> 1)) {
		rsum[rt] += rsum[rt << 1];
	}
	msum[rt] = max(lsum[rt << 1 | 1] + rsum[rt << 1], max(msum[rt << 1], msum[rt << 1 | 1]));
}
void build(int l, int r, int rt) {
	msum[rt] = lsum[rt] = rsum[rt] = r - l + 1;
	cover[rt] = -1;
	if (l == r) return;
	int m = (l + r) >> 1;
	build(lson);
	build(rson);
}
void update(int L, int R, int d, int l, int r, int rt) {	//区间替换
	if (l >= L && r <= R) {
		msum[rt] = lsum[rt] = rsum[rt] = d ? 0 : r - l + 1;
		cover[rt] = d;
		return;
	}
	pushDown(rt, r - l + 1);
	int m = (l + r) >> 1;
	if (L <= m) update(L, R, d, lson);
	if (R > m) update(L, R, d, rson);
	pushUp(rt, r - l + 1);
}
int query(int w, int l, int r, int rt) {	//查询满足条件的左端点
	if (l == r) return l;
	pushDown(rt, r - l + 1);
	int m = (l + r) >> 1;
	if (msum[rt << 1] >= w) return query(w, lson);
	else if (rsum[rt << 1] + lsum[rt << 1 | 1] >= w) return m - rsum[rt << 1] + 1;
	return query(w, rson);
}
int main(){
	int n, m;
	scanf("%d%d", &n, &m);
	build(1, n, 1);
	while (m--) {
		int op, v1, v2;
		scanf("%d", &op);
		if (op == 1) {
			scanf("%d", &v1);
			if (msum[1] < v1) {
				puts("0");
			}
			else {
				int left = query(v1, 1, n, 1);
				printf("%d\n", left);
				update(left, left + v1 - 1, 1, 1, n, 1);
			}
		}
		else if(op == 2){
			scanf("%d%d", &v1, &v2);
			update(v1, v1 + v2 - 1, 0, 1, n, 1);
		}
	}
	return 0;
}

 

  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值