HDU - 1695 GCD(欧拉函数+容斥原理)

Description

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs. 
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same. 

Yoiu can assume that a = c = 1 in all test cases. 

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases. 
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above. 

Output

For each test case, print the number of choices. Use the format in the example. 

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427


        



#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define LL long long
const int maxn = 1e5 + 5;
int a, b, c, d, e;
int phi[maxn], prime[maxn] = { 0 }, tol = 0;
int nsu[maxn], no;
LL ans, sum;
void init()
{
	phi[1] = 1;
	for (int i = 2; i < maxn; i++)
	if (!phi[i])
	{
		prime[tol++] = i;
		for (int j = i; j < maxn; j += i)
		{
			if (!phi[j])
				phi[j] = j;
			phi[j] = phi[j] / i*(i - 1);
		}
	}
}


void dfs(int i, int x, int xu, int nu)  //当前第几个素数,已选几个素数,需要几个素数,素数乘积……编程规范真差!
{
	if (x == xu)
	{
		sum += (LL)b / nu; 
		return;
	}
	if (i == no)
		return;
	dfs(i + 1, x + 1, xu, nu*nsu[i]);
	dfs(i + 1, x, xu, nu);
}

LL rong()
{
	LL ret = 0;
	for (int i = 1; i <= no; i++)
	{
		sum = 0;
		dfs(0, 0, i, 1);
		if (i & 1) ret += sum;
		else ret -= sum;
	}
	return (LL)b - ret;		//这里的ret是能被它素因子整除的数量,所以必须求反返回
}

int main()
{
	init();
	int T,cas = 1;
	scanf("%d", &T);
	while (T--)
	{
		scanf("%d%d%d%d%d", &a, &b, &c, &d, &e);
		if (e == 0)
		{
			printf("Case %d: 0\n", cas++);
			continue;
		}
		b /= e; d /= e;
		if (b > d) swap(b, d);
		ans = 0;
		for (int i = 1; i <= b; i++)
			ans += (LL)phi[i];
		for (int i = b + 1; i <= d; i++)
		{
			a = i;
			no = 0;
			for (int j = 0; j < tol&&prime[j] * prime[j] <= a&&prime[j] <= b; j++)
			{
				if (a%prime[j] == 0)
				{
					nsu[no++] = prime[j];
					while (a%prime[j] == 0)
						a /= prime[j];
				}
			}
			if (a>1)			//当出现大素数的时候
				nsu[no++] = a;
			ans += rong();
		}
		printf("Case %d: %I64d\n", cas++, ans);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值