Android提示:使用或覆盖了已过时的 API

Android在编译时,出现类似提示:

注: 某些输入文件使用或覆盖了已过时的 API。
注: 有关详细信息, 请使用 -Xlint:deprecation 重新编译。

解决方法:

1、在build.gradle配置文件中的android节点下,添加如下配置信息:

android {

    ...

    //添加此配置的作用:让过时的api或者不合规矩的语法展现出来
    gradle.projectsEvaluated {
        tasks.withType(JavaCompile) {
            options.compilerArgs << "-Xlint:unchecked" << "-Xlint:deprecation"
        }
    }

}

2、运行项目,然后根据提示找出过时的api或者不合规矩的语法进行修改即可。

已标记关键词 清除标记