程序设计基础44 PAT A1095

1095 Cars on Campus (30 分)

Zhejiang University has 8 campuses and a lot of gates. From each gate we can collect the in/out times and the plate numbers of the cars crossing the gate. Now with all the information available, you are supposed to tell, at any specific time point, the number of cars parking on campus, and at the end of the day find the cars that have parked for the longest time period.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (≤10​4​​), the number of records, and K (≤8×10​4​​) the number of queries. Then N lines follow, each gives a record in the format:

plate_number hh:mm:ss status

where plate_number is a string of 7 English capital letters or 1-digit numbers; hh:mm:ss represents the time point in a day by hour:minute:second, with the earliest time being 00:00:00 and the latest 23:59:59; and status is either in or out.

Note that all times will be within a single day. Each in record is paired with the chronologically next record for the same car provided it is an out record. Any in records that are not paired with an out record are ignored, as are out records not paired with an in record. It is guaranteed that at least one car is well paired in the input, and no car is both in and out at the same moment. Times are recorded using a 24-hour clock.

Then K lines of queries follow, each gives a time point in the format hh:mm:ss. Note: the queries are given in accending order of the times.

Output Specification:

For each query, output in a line the total number of cars parking on campus. The last line of output is supposed to give the plate number of the car that has parked for the longest time period, and the corresponding time length. If such a car is not unique, then output all of their plate numbers in a line in alphabetical order, separated by a space.

Sample Input:

16 7
JH007BD 18:00:01 in
ZD00001 11:30:08 out
DB8888A 13:00:00 out
ZA3Q625 23:59:50 out
ZA133CH 10:23:00 in
ZD00001 04:09:59 in
JH007BD 05:09:59 in
ZA3Q625 11:42:01 out
JH007BD 05:10:33 in
ZA3Q625 06:30:50 in
JH007BD 12:23:42 out
ZA3Q625 23:55:00 in
JH007BD 12:24:23 out
ZA133CH 17:11:22 out
JH007BD 18:07:01 out
DB8888A 06:30:50 in
05:10:00
06:30:50
11:00:00
12:23:42
14:00:00
18:00:00
23:59:00

Sample Output:

1
4
5
2
1
0
1
JH007BD ZD00001 07:20:09

一,关键之处

1,是对每项记录建立结构体,不是对每辆车建立结构体,对每辆车建立结构体会考虑这辆车好几次的结束和开始时间。

2,对记录筛选的时候要把这项合格数据归到一个新的结构体内,用来进行单个时间点的查询。

3,用map存放最长时间,好处是有新的id可以添加,有旧的id可以在它的基础上增加时间。

4,用map进行查询的方法

map<string, int>::iterator it;
	for (it = Parking.begin(); it != Parking.end(); it++) {
		if (it->second == max_time) {
			printf("%s ", it->first.c_str());
		}
	}

5,进行车来车往查询的时候 now放在查询之前,因为题目最后的ascending表示查询时间是递增的,递增的话now就不用每个查询开始的时候重新归零了。

二,我的代码

#include<cstdio>
#include<cstring>
#include<string>
#include<algorithm>
#include<map>
using namespace std;
const int max_n = 10010;
struct Record {
	char id[12];
	char status[5];
	int time;
}record[max_n], valid[max_n];
map<string, int> Parking;
int convertion(int hh, int mm, int ss) {
	return hh * 3600 + mm * 60 + ss;
}
bool cmpIdAndTime(Record A, Record B) {
	if (strcmp(A.id, B.id) != 0)return strcmp(A.id, B.id) < 0;
	else {
		return A.time < B.time;
	}
}
bool cmpTime(Record A, Record B) {
	return A.time < B.time;
}
int main() {
	int N = 0, K = 0, num = 0;
	int hh = 0, mm = 0, ss = 0, time = 0;
	char status[5];
	scanf("%d %d", &N, &K);
	for (int i = 0; i < N; i++) {
		scanf("%s %d:%d:%d %s", record[i].id, &hh, &mm, &ss, record[i].status);
		time = convertion(hh, mm, ss);
		record[i].time = time;
	}
	sort(record, record + N, cmpIdAndTime);
	int max_time = -1, lasting = 0;
	for (int i = 0; i < N - 1; i++) {
		if (!(strcmp(record[i].id, record[i + 1].id)) && (!strcmp(record[i].status, "in")) && !(strcmp(record[i + 1].status, "out"))) {
			lasting = record[i + 1].time - record[i].time;
			valid[num++] = record[i];
			valid[num++] = record[i + 1];
			if (Parking.count(record[i].id) == 0) {
				Parking[record[i].id] = 0;
			}
			Parking[record[i].id] += lasting;
			max_time = max(max_time, Parking[record[i].id]);
		}
	}
	sort(valid, valid + num, cmpTime);
	int numCar = 0, now = 0;
	for (int i = 0; i < K; i++) {
		scanf("%d:%d:%d", &hh, &mm, &ss);
		time = convertion(hh, mm, ss);
		while (now < num&&valid[now].time <= time) {
			if (strcmp(valid[now].status, "in") == 0) {
				numCar++;
			}
			else {
				numCar--;
			}
			now++;
		}
		printf("%d\n", numCar);
	}
	map<string, int>::iterator it;
	for (it = Parking.begin(); it != Parking.end(); it++) {
		if (it->second == max_time) {
			printf("%s ", it->first.c_str());
		}
	}
	printf("%02d:%02d:%02d\n", max_time / 3600, max_time % 3600 / 60, max_time % 60);
	return 0;
}

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值