程序设计基础55 two_pointers解决内存超限

1029 Median (25 分)

Given an increasing sequence S of N integers, the median is the number at the middle position. For example, the median of S1 = { 11, 12, 13, 14 } is 12, and the median of S2 = { 9, 10, 15, 16, 17 } is 15. The median of two sequences is defined to be the median of the nondecreasing sequence which contains all the elements of both sequences. For example, the median of S1 and S2 is 13.

Given two increasing sequences of integers, you are asked to find their median.

Input Specification:

Each input file contains one test case. Each case occupies 2 lines, each gives the information of a sequence. For each sequence, the first positive integer N (≤2×10​5​​) is the size of that sequence. Then N integers follow, separated by a space. It is guaranteed that all the integers are in the range of long int.

Output Specification:

For each test case you should output the median of the two given sequences in a line.

Sample Input:

4 11 12 13 14
5 9 10 15 16 17

Sample Output:

13

一,注意点

1,此题内存超限的原因是若是把那两个数组全部输入的话内存肯定是不够用的。所以需要做的事情是使一个数组全部输入,另一个数组直接以数字的形式存储。

2,用1项的方法解决问题肯定会遇到繁琐的下标问题,其实只要把每个变量代表的意义弄明白,实现起来还是很得心应手的。count代表已经比较完的数目,i和j代表即将进行比较的项目。所以此时的mid不应当是恰好中位数的排位(从1开始),应当是中位数排位的前一个,即mid=(l1+l2-1)/2,若不减去这个1则恰好是中位数的排位。这样的话count=mid的时候退出循环,输出的是即将比较的i和j中最小的那个数值。

3,记得哪个数组先比完,要在这个数组的最后加一个INF,防止这个数组的值都比另一个数组都小的时候指针越过数组的下标。

4,可以学习一下用malloc写法表示数组。

二,正确代码

#include<cstdio>
#include<cstdlib>
using namespace std;
const int INF = 0x7fffffff;
int main() {
	int l1 = 0, l2 = 0;
	int *a1, a2 = 0, count = 0, mid = 0;
	int i = 0, j = 0;
	scanf("%d", &l1);
	a1 = (int*)malloc((l1 + 1) * sizeof(int));
	for (int i = 0; i < l1; i++) {
		scanf("%d", a1 + i);
	}
	*(a1 + l1) = INF;
	scanf("%d", &l2);
	scanf("%d", &a2);
	mid = (l1 + l2 - 1) / 2;
	while (count < mid) {
		if (*(a1 + i) < a2)i++;
		else {
			j++;
			if (j != l2) {
				scanf("%d", &a2);
			}
			else if (j == l2) {
				a2 = INF;
			}
		}
		count++;
	}
	printf("%d", *(a1 + i) < a2 ? *(a1 + i) : a2);
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值