程序设计基础67 STL之set中查找相同元素最后不用平方级轮子

1063 Set Similarity (25 分)

Given two sets of integers, the similarity of the sets is defined to be N​c​​/N​t​​×100%, where N​c​​ is the number of distinct common numbers shared by the two sets, and N​t​​ is the total number of distinct numbers in the two sets. Your job is to calculate the similarity of any given pair of sets.

Input Specification:

Each input file contains one test case. Each case first gives a positive integer N (≤50) which is the total number of sets. Then N lines follow, each gives a set with a positive M (≤10​4​​) and followed by M integers in the range [0,10​9​​]. After the input of sets, a positive integer K (≤2000) is given, followed by K lines of queries. Each query gives a pair of set numbers (the sets are numbered from 1 to N). All the numbers in a line are separated by a space.

Output Specification:

For each query, print in one line the similarity of the sets, in the percentage form accurate up to 1 decimal place.

Sample Input:

3
3 99 87 101
4 87 101 5 87
7 99 101 18 5 135 18 99
2
1 2
1 3

Sample Output:

50.0%
33.3%

一,注意点

1,查找两个set中的相同元素不用两个平方级的for,以后最好也杜绝这种第二个for从头开始的写法,会超时的。

2,set中的常见操作时间复杂度,insert()为O(logN),find()为O(logN),erase()单个元素为O(1),erase()两个元素为O(last-first),size()为O(1),clear()为O(N).

别忘了用这些set的自带函数。

二,我的代码

#include<cstdio>
#include<set>
using namespace std;
const int max_n = 55;
set<int> set_list[max_n];
void comparing(int set_1, int set_2) {
	int total_size = 0, total_num = 0, same_num = 0;
//	double ans = 0;
	for (set<int>::iterator it = set_list[set_1].begin(); it != set_list[set_1].end(); it++) {
		if (set_list[set_2].find(*it) != set_list[set_2].end()) {
			same_num++;
		}
	}
	total_size = set_list[set_1].size() + set_list[set_2].size();
	total_num = total_size - same_num;
	printf("%.1f%%\n", 100.0 * same_num / total_num);
}
int main() {
	int N = 0;
	int num = 0;
	int factor = 0;
	scanf("%d", &N);
	for (int i = 1; i <= N; i++) {
		scanf("%d", &num);
		for (int j = 0; j < num; j++) {
			scanf("%d", &factor);
			set_list[i].insert(factor);
		}
	}
	int set_1 = 0, set_2 = 0;
	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		scanf("%d %d", &set_1, &set_2);
		comparing(set_1, set_2);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值