程序设计基础69 STL之map

1100 Mars Numbers (20 分)

People on Mars count their numbers with base 13:

  • Zero on Earth is called "tret" on Mars.
  • The numbers 1 to 12 on Earch is called "jan, feb, mar, apr, may, jun, jly, aug, sep, oct, nov, dec" on Mars, respectively.
  • For the next higher digit, Mars people name the 12 numbers as "tam, hel, maa, huh, tou, kes, hei, elo, syy, lok, mer, jou", respectively.

For examples, the number 29 on Earth is called "hel mar" on Mars; and "elo nov" on Mars corresponds to 115 on Earth. In order to help communication between people from these two planets, you are supposed to write a program for mutual translation between Earth and Mars number systems.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<100). Then N lines follow, each contains a number in [0, 169), given either in the form of an Earth number, or that of Mars.

Output Specification:

For each number, print in a line the corresponding number in the other language.

Sample Input:

4
29
5
elo nov
tam

Sample Output:

hel mar
may
115
13

一,注意点

1,要学会使用getline(cin,str),同时还要学会使用substr(start,len),start为开始的下标,len为截取的长度。

2,本题最好的方法是把0到168这些数字进行打表,对输入的例子直接查询即可。由于时间原因,不再给出这种最好方法。

二,我的代码

#include<iostream>
#include<string>
#include<map>
using namespace std;
string single[14] = { "tret","jan","feb","mar","apr","may","jun","jly","aug","sep","oct","nov","dec" };
string decimal[14] = { "tret","tam","hel","maa","huh","tou","kes","hei","elo","syy","lok","mer","jou" };
map<string, int> mars_single;
map<string, int> mars_decimal;
int str_to_num(string str) {
	int len = str.length();
	int ans = 0;
	for (int i = 0; i < len; i++) {
		ans = ans * 10 + str[i] - '0';
	}
	return ans;
}
int main() {
	int N = 0;
	string factor;
	int factor_1 = 0;
	for (int i = 0; i < 13; i++) {
		mars_single[single[i]] = i;
	}
	for (int i = 0; i < 13; i++) {
		mars_decimal[decimal[i]] = i;
	}
	scanf("%d", &N);
	getchar();
	for (int i = 0; i < N; i++) {
//		getchar();
		getline(cin, factor);
		if (factor[0] >= '0'&&factor[0] <= '9') {
			factor_1 = str_to_num(factor);
			if (factor_1 / 13 != 0) {
				cout << decimal[factor_1 / 13];
				if (factor_1 % 13 != 0) {
					cout << " "<<single[factor_1 % 13] << endl;
				}
				else {
					cout << endl;
				}
			}
			else {
				cout <<single[factor_1 % 13] << endl;
			}
		}
		else{
			int ans = 0;
			string mars_shi, mars_ge;
//			getchar();
//			getline(cin, factor);
			if (factor.find(" ") != string::npos) {
				mars_shi = factor.substr(0, factor.find(" "));
				mars_ge = factor.substr(factor.find(" ") + 1, factor.length() - 1 - factor.find(" "));
				ans = mars_decimal[mars_shi] * 13 + mars_single[mars_ge];
				cout << ans << endl;
			}
			else {
				if (mars_single.count(factor) != 0) {
					cout << mars_single[factor] << endl;
				}
				else {
					cout << mars_decimal[factor]*13 << endl;
				}
			}
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
辽B代驾管理系统对代驾订单管理、用户咨询管理、代驾订单评价管理、代驾订单投诉管理、字典管理、论坛管理、公告管理、新闻信息管理、司机管理、用户管理、管理员管理等进行集中化处理。经过前面自己查阅的网络知识,加上自己在学校课堂上学习的知识,决定开发系统选择小程序模式这种高效率的模式完成系统功能开发。这种模式让操作员基于浏览器的方式进行网站访问,采用的主流的Java语言这种面向对象的语言进行辽B代驾管理系统程序的开发,在数据库的选择上面,选择功能强大的Mysql数据库进行数据的存放操作。辽B代驾管理系统的开发让用户查看代驾订单信息变得容易,让管理员高效管理代驾订单信息。 辽B代驾管理系统具有管理员角色,用户角色,这几个操作权限。 辽B代驾管理系统针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理代驾订单信息,管理公告信息等内容。 辽B代驾管理系统针对用户设置的功能有:查看并修改个人信息,查看代驾订单信息,查看公告信息等内容。 辽B代驾管理系统针对管理员设置的功能有:添加并管理各种类型信息,管理用户账户信息,管理代驾订单信息,管理公告信息等内容。 辽B代驾管理系统针对用户设置的功能有:查看并修改个人信息,查看代驾订单信息,查看公告信息等内容。 系统登录功能是程序必不可少的功能,在登录页面必填的数据有两项,一项就是账号,另一项数据就是密码,当管理员正确填写并提交这二者数据之后,管理员就可以进入系统后台功能操作区。项目管理页面提供的功能操作有:查看代驾订单,删除代驾订单操作,新增代驾订单操作,修改代驾订单操作。公告信息管理页面提供的功能操作有:新增公告,修改公告,删除公告操作。公告类型管理页面显示所有公告类型,在此页面既可以让管理员添加新的公告信息类型,也能对已有的公告类型信息执行编辑更新,失效的公告类型信息也能让管理员快速删除。新闻管理页面,此页面提供给管理员的功能有:新增新闻,修改新闻,删除新闻。新闻类型管理页面,此页面提供给管理员的功能有:新增新闻类型,修改新闻类型,删除新闻类型。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值