程序设计基础78 tips 关于代码整洁性问题

1043 Is It a Binary Search Tree (25 分)

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

 一,注意事项

1,本题不难,但是各个模块繁琐不堪,最好的方法是所有序列都用vector存储,然后提前求出先序,镜像树先序,后序,镜像树后序。最后三个if判断即可。

二,我的代码(繁琐版)

#include<cstdio>
#include<algorithm>
using namespace std;
const int max_n = 1100;
int N = 0;
int countting = 0;
int arr[max_n], pre[max_n], post[max_n];
struct node {
	int data;
	node *lchild;
	node *rchild;
};
void insert(node* &root,int num) {
	if (root == NULL) {
		root = new node;
		root->data = num;
		root->lchild = NULL;
		root->rchild = NULL;
	}
	else if (num < root->data) {
		insert(root->lchild, num);
	}
	else {
		insert(root->rchild, num);
	}
}
node *create() {
	node *root = NULL;
	for (int i = 0; i < N; i++) {
		insert(root, arr[i]);
	}
	return root;
}
/*void swap_node(node *root) {
	if (root == NULL) {
		return;
	}

	if (root->lchild != NULL)swap_node(root->lchild);
	if (root->rchild != NULL)swap_node(root->rchild);
}*/
void swap_node_travel(node *root) {
	if (root == NULL) {
		return;
	}
	pre[countting++] = root->data;
	swap_node_travel(root->rchild);
	swap_node_travel(root->lchild);
}
void pre_travel(node *root) {
	if (root == NULL)return;
	pre[countting++] = root->data;
	pre_travel(root->lchild);
	pre_travel(root->rchild);
}
void post_travel(node *root) {
	if (root == NULL)return;
	post_travel(root->lchild);
	post_travel(root->rchild);
	post[countting++] = root->data;
}
void post_travel_mirror(node *root) {
	if (root == NULL)return;
	post_travel_mirror(root->rchild);
	post_travel_mirror(root->lchild);
	post[countting++] = root->data;
}
bool checking() {
	for (int i = 0; i < N; i++) {
		if (arr[i] != pre[i]) {
			return false;
		}
	}
	return true;
}
void print_arr() {
	for (int i = 0; i < N; i++) {
		printf("%d", post[i]);
		if (i != N - 1) {
			printf(" ");
		}
	}
}
int main() {
	node *root;
	scanf("%d", &N);
	for (int i = 0; i < N; i++) {
		scanf("%d", &arr[i]);
	}
	root = create();
	pre_travel(root);
	if (checking()) {
		countting = 0;
		post_travel(root);
		printf("YES\n");
		print_arr();
		return 0;
	}
	else {
		countting = 0;
		swap_node_travel(root);
		if (checking()) {
			countting = 0;
			post_travel_mirror(root);
			printf("YES\n");
			print_arr();
			return 0;
		}
	}
	printf("NO\n");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值