1043 Is It a Binary Search Tree (25分) 二叉搜索树 遍历 恶心题

A Binary Search Tree (BST) is recursively defined as a binary tree which has the following properties:

  • The left subtree of a node contains only nodes with keys less than the node's key.
  • The right subtree of a node contains only nodes with keys greater than or equal to the node's key.
  • Both the left and right subtrees must also be binary search trees.

If we swap the left and right subtrees of every node, then the resulting tree is called the Mirror Image of a BST.

Now given a sequence of integer keys, you are supposed to tell if it is the preorder traversal sequence of a BST or the mirror image of a BST.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (≤1000). Then N integer keys are given in the next line. All the numbers in a line are separated by a space.

Output Specification:

For each test case, first print in a line YES if the sequence is the preorder traversal sequence of a BST or the mirror image of a BST, or NO if not. Then if the answer is YES, print in the next line the postorder traversal sequence of that tree. All the numbers in a line must be separated by a space, and there must be no extra space at the end of the line.

Sample Input 1:

7
8 6 5 7 10 8 11

Sample Output 1:

YES
5 7 6 8 11 10 8

Sample Input 2:

7
8 10 11 8 6 7 5

Sample Output 2:

YES
11 8 10 7 5 6 8

Sample Input 3:

7
8 6 8 5 10 9 11

Sample Output 3:

NO

 吾:  代码有问题  写得烂   留着为诫

#include <iostream>
#include <vector>

using namespace std;

const int maxn = 1006;

int n;
int post[maxn], pre[maxn], v[maxn];

void getv(int root, int t)
{

	//if (root >= n)
	//{
	//	//index++;
	//	return;
	//}
	if (v[root]==0)
	{
		v[root] = t;

		return;
	}
	if (t<v[root])
	{
		getv(root * 2 + 1, t);
	}
	else
	{
		getv(root * 2 + 2, t);
	}
	return;
}

bool check()//dfs看是否满足bst平衡二叉树
{
	bool flag = true;
	for (int i = 0; i < n / 2; i++)
	{
		if (v[0] > v[1])
		{
			if (v[i] <= v[i * 2 + 1] || v[i] > v[i * 2 + 2])
			{
				flag = false;
				return flag;
			}
		}
		else
		{
			if (v[i] > v[i * 2 + 1] || v[i] <= v[i * 2 + 2])
			{
				flag = false;
				return flag;
			}
		}
	}
	return flag;
}

void postOrder(int root)//遍历后序
{
	if (root >= n)
	{
		return;
	}
	postOrder(root * 2 + 1);
	postOrder(root * 2 + 2);
	cout << v[root];
	if (root != 0)
	{
		cout << " ";
	}
}

int main()
{
	freopen("in.txt", "r", stdin);

	cin >> n;
	int index = 0;
	for (int i = 0; i < n; i++)
	{
		scanf("%d", &pre[i]);
		getv(0, pre[i]);
	}
	
	
	if (check())
	{
		cout << "YES" << endl;
		postOrder(0);
	}
	else
	{
		cout << "NO" << endl;
	}

	return 0;
}

 

 因为这三个点不过,想到了二叉搜索树如果不是完全二叉树,中间缺点的情况。通过自己制造了一组中间缺点的数据用柳的代码试过后,发现确实自己的代码和柳的区别在于不能适用于缺点的情况:制造的数据:8 6 3 10 9 11

自己的:

柳:

柳代码:

#include <iostream>
#include <vector>

using namespace std;

bool ismirror;
vector<int> pre, post;
void getpost(int root, int tail)
{
	if (root>tail)
	{
		return;
	}
	int i = root + 1, j = tail;
	if (!ismirror)
	{
		while (i<=tail&&pre[root]>pre[i])
		{
			i++;
		}
		while (j>root&&pre[root]<=pre[j])
		{
			j--;
		}
	}
	else
	{
		while (i<=tail&&pre[root]<=pre[i])
		{
			i++;
		}
		while (j>root&&pre[root]>pre[j])
		{
			j++;
		}
	}
	if (i-j!=1)
	{
		return;
	}
	getpost(root + 1, j);
	getpost(i, tail);
	post.push_back(pre[root]);
}

int main()
{
	freopen("in.txt", "r", stdin);
	int n;
	cin >> n;
	pre.resize(n);
	for (int i = 0; i < n; i++)
	{
		cin >> pre[i];
	}
	getpost(0, n - 1);
	if (post.size()!=n)
	{
		ismirror = true;
		post.clear();
		getpost(0, n - 1);
	}
	if (post.size()==n)
	{
		printf("YES\n%d", post[0]);
		for (int i = 1; i < n; i++)
		{
			printf(" %d", post[i]);
		}
	}
	else
	{
		printf("NO");
	}
	return 0;
}

这个程序也过,很有意思:这个思路很好!!!好理解而且代码简约!

这个做法:先建树,不管是否为镜像,都是左小右大,然后如果不是镜像,那么对树进行的前序遍历就和题目给的前序一样,遍历的时候记录了树的后序,直接输出;如果是镜像,实际树是左大右小,你建的树为左小右大,所以第一次前序遍历肯定和题目给的不同,此时,再来一次前序遍历,遍历顺序稍加更改,(因为建树不管是否镜像都是左小右大)刚才是先左后右,这次是先右后左。如果此次先序遍历和题目的一样,那么就是镜像,否则,啥也不是。

#include<iostream>
#include<cstring>
#include<vector>
#include<map>
#include<cstdio>
#include<algorithm>

using namespace std;

struct Node {
	Node *l, *r;
	int d;
};
vector<int> pre, tmp, ans;
bool flag = false;
int i;
void insert(Node* &root, int data) {
	if (root == NULL) {
		root = new Node;
		root->d = data;
		root->l = root->r = NULL;
		return;
	}
	if (data < root->d) {
		insert(root->l, data);
	}
	else 	insert(root->r, data);
	return;
}

void Pre(Node *root) {
	if (root == NULL) return;

	tmp.push_back(root->d);

	if (flag) {
		Pre(root->r);
		Pre(root->l);
		ans.push_back(root->d);
	}
	else {
		Pre(root->l);
		Pre(root->r);
		ans.push_back(root->d);
	}
}

int maxL = 1;
int main() {
	int n;
	freopen("in.txt", "r", stdin);
	cin >> n;
	Node *root = NULL;
	for (int i = 0; i < n; i++) {
		int t;

		cin >> t;
		pre.push_back(t);
		insert(root, t);
	}
	ans.clear();
	Pre(root);
	if (tmp != pre) {
		flag = true;
		ans.clear();
		tmp.clear();

		Pre(root);
	}
	if (tmp == pre) {
		cout << "YES" << endl;
		for (i = 0; i < ans.size() - 1; i++) {
			cout << ans[i] << " ";
		}
		cout << ans[i] << endl;

	}
	else
		cout << "NO" << endl;

	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值