hdu 2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 11778    Accepted Submission(s): 5177


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 
题意:

h*w的木板,放进一些1*L的物品,求每次放空间能容纳且最上边的位子。

做法:

因为每个announcement的高都是1,所以把一整块board 90度旋转,h为宽,w为高,线段树的叶子就是原来board的每一行。 

注意一点,一开始看到board的长和宽有10^9这么多,还以为要离散化,其实是不用的,因为announcement贴上去以后不会被覆盖,所以最多就是有200,000张长度为10^9的announcement,即线段树最多只有200,000个叶子,所以建树的时候要在h和n之间取最小值。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include<map>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL unsigned long long
#define inf 0x0f0f0f0f
using namespace std;
struct Node
{
    int left,right;
    int val,idx;
};
int w,h;
Node T[200005<<2];
void build(int cur,int l,int r)
{
    T[cur].left=l;
    T[cur].right=r;
    T[cur].val=w;
    T[cur].idx=l;
    if(l!=r)
    {
        build(2*cur,l,(l+r)/2);
        build(2*cur+1,(l+r)/2+1,r);
    }
    else
        return;
}
int query(int cur,int x)
{
    if(T[cur].val<x)
        return -1;
    else if(T[cur].left==T[cur].right)
        return T[cur].idx;
    else
    {
        int ans=0;
        if(x<=T[cur*2].val)
            ans=query(2*cur,x);
        else
            ans=query(2*cur+1,x);
        return ans;
    }
}
void change(int cur,int x,int del)
{
    if(T[cur].left==T[cur].right)
        T[cur].val-=del;
    else
    {
        if(x<=(T[cur].left+T[cur].right)/2)
            change(2*cur,x,del);
        if(x>(T[cur].left+T[cur].right)/2)
            change(2*cur+1,x,del);
        if(T[2*cur].val>=T[2*cur+1].val)
        {
            T[cur].val=T[2*cur].val;
            T[cur].idx=T[2*cur].idx;
        }
        if(T[2*cur+1].val>T[2*cur].val)
        {
            T[cur].val=T[2*cur+1].val;
            T[cur].idx=T[2*cur+1].idx;
        }
    }
}
int main()
{
    int t,x,tt;
    int n,m,i;
    while(scanf("%d%d%d",&h,&w,&n)!=EOF)
    {
        tt=min(h,n);
        build(1,1,tt);
        for(i=0;i<n;i++)
        {
            scanf("%d",&x);
            tt=query(1,x);
            if(tt==-1)
                printf("-1\n");
            else
            {
                printf("%d\n",tt);
                change(1,tt,x);
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值