poj 3468

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 65592 Accepted: 20196
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

Source

POJ Monthly--2007.11.25, Yang Yi

题意:线段树区间增减。

#include <iostream>
#include <cstdio>
#include <climits>
#include <cstring>
#include <cstdlib>
#include <cmath>
#include <vector>
#include <queue>
#include<map>
#include <algorithm>
#include<ctime>
#define esp 1e-6
#define LL long long
#define inf 0x0f0f0f0f
using namespace std;
struct Node
{
    LL left,right;
    LL sum;
    LL delta;
};
Node T[100005<<2];
int res;
void build(LL cur,LL l,LL r)
{
    T[cur].left=l;
    T[cur].right=r;
    T[cur].delta=0;
    if(l==r)
    {
        LL a;
        scanf("%lld",&a);
        T[cur].sum=a;
        return;
    }
    else
    {
        build(2*cur,l,(l+r)/2);
        build(2*cur+1,(l+r)/2+1,r);
        T[cur].sum=T[2*cur].sum+T[cur*2+1].sum;
    }
}
void update(LL cur)
{
    T[cur*2].sum+=T[cur].delta*(T[cur*2].right-T[cur*2].left+1);
    T[cur*2+1].sum+=T[cur].delta*(T[cur*2+1].right-T[cur*2+1].left+1);
    T[cur*2].delta+=T[cur].delta;
    T[cur*2+1].delta+=T[cur].delta;
    T[cur].delta=0;
}
LL query(LL cur,LL l,LL r)
{
    if(l<=T[cur].left&&T[cur].right<=r)
        return T[cur].sum;
    else
    {
        if(T[cur].delta!=0)
            update(cur);
        LL ans=0;
        if(l<=(T[cur].left+T[cur].right)/2)
            ans+=query(cur*2,l,r);
        if(r>(T[cur].left+T[cur].right)/2)
            ans+=query(cur*2+1,l,r);
        return ans;
    }
}
void change(LL cur,LL l,LL r,LL delta)
{
    if(l<=T[cur].left&&T[cur].right<=r)
    {
        T[cur].sum+=delta*(T[cur].right-T[cur].left+1);
        T[cur].delta+=delta;
    }
    else
    {
        if(T[cur].delta!=0)
            update(cur);
        if(l<=(T[cur].left+T[cur].right)/2)
            change(cur*2,l,r,delta);
        if(r>(T[cur].left+T[cur].right)/2)
            change(cur*2+1,l,r,delta);
        T[cur].sum=T[cur*2].sum+T[cur*2+1].sum;
    }
}
int main()
{
    int t,cas;
    LL n,q;
    LL a,b,x;
    LL i;
    char c[10];
    while(scanf("%lld%lld",&n,&q)!=EOF)
    {
        build(1,1,n);
        while(q--)
        {
            scanf("%s",c);
            if(c[0]=='C')
            {
                scanf("%lld%lld%lld",&a,&b,&x);
                change(1,a,b,x);
            }
            else
            {
                scanf("%lld%lld",&a,&b);
                printf("%lld\n",query(1,a,b));
            }
        }
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值