POJ 3468 线段树

http://poj.org/problem?id=3468

You have N integers, A1, A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1, A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of Aa, Aa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of Aa, Aa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.

题目大意:给出n个数和m个操作,Q a b,则输出区间[a,b]的和;Q a b c,则把区间[a,b]的所有元素都加上c。

思路:线段树,因为涉及到区间修改,所以要用到lazy标记。

线段树基本知识:https://blog.csdn.net/xiji333/article/details/87973714

#include<iostream>
#include<cstdio>
#define INF 0x3f3f3f3f
typedef long long ll;
using namespace std;

struct node
{
	ll l,r;
	ll sum;
	ll lazy;	//lazy标记
};

node tree[100000*4+5];
ll a[100005];
ll n,m;

void build(ll i,ll l,ll r)
{
	tree[i].l=l,tree[i].r=r;
	if(l==r)
	{
		tree[i].sum=a[l];
		return ;
	}
	ll mid=(l+r)>>1;
	build(i<<1,l,mid);	//左子树
	build(i<<1|1,mid+1,r);	//右子树
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;//区间和
}

void down(ll i)//节点i的标记下传
{
	tree[i<<1].lazy+=tree[i].lazy;	//lazy标记下传
	tree[i<<1|1].lazy+=tree[i].lazy;
	tree[i<<1].sum+=tree[i].lazy*(tree[i<<1].r-tree[i<<1].l+1);//修改值
	tree[i<<1|1].sum+=tree[i].lazy*(tree[i<<1|1].r-tree[i<<1|1].l+1);
	tree[i].lazy=0;
}

void update(ll i,ll l,ll r,ll v)
{
	if(tree[i].l==l&&tree[i].r==r)//要修改的区间就是当前区间
	{
		tree[i].sum+=(tree[i].r-tree[i].l+1)*v;//修改区间值
		tree[i].lazy+=v;	//修改lazy标记
		return ;
	}
	if(tree[i].lazy)//走到这一步说明要用到子节点了 lazy下传
		down(i);
	ll mid=(tree[i].l+tree[i].r)>>1;
	if(r<=mid)//左半区间
		update(i<<1,l,r,v);
	else if(l>=mid+1)//右半区间
		update(i<<1|1,l,r,v);
	else //左右均有
	{
		update(i<<1,l,mid,v);
		update(i<<1|1,mid+1,r,v);
	}
	tree[i].sum=tree[i<<1].sum+tree[i<<1|1].sum;
}

ll query(ll i,ll l,ll r)
{
	if(tree[i].l==l&&tree[i].r==r)//要查询的区间就是当前区间
		return tree[i].sum;
	if(tree[i].lazy)//要用到子节点 lazy下传
		down(i);
	ll mid=(tree[i].l+tree[i].r)>>1;
	if(r<=mid)//左半部分
		return query(i<<1,l,r);
	else if(l>=mid+1)	//右半部分
		return query(i<<1|1,l,r);
	else //左右均有
		return query(i<<1,l,mid)+query(i<<1|1,mid+1,r);
}

int main()
{
	scanf("%lld %lld",&n,&m);
	for(ll i=1;i<=n;i++)
		scanf("%lld",&a[i]);
	build(1,1,n);
	char ch;
	ll t1,t2,t3;
	for(ll i=0;i<m;i++)
	{
		getchar();
		ch=getchar();
		if(ch=='Q')
		{
			scanf("%lld%lld",&t1,&t2);
			printf("%lld\n",query(1,t1,t2));
		}
		else if(ch=='C')
		{
			scanf("%lld%lld%lld",&t1,&t2,&t3);
			update(1,t1,t2,t3);
		}
	}
	return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值