poj2083 Fractal

12 篇文章 0 订阅
Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 7870 Accepted: 3788

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 
  • A box fractal of degree 1 is simply 

  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
            B(n - 1)
    
    B(n - 1)        B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-

Source

Shanghai 2004 Preliminary


题意:直接看图。

做法:递归。

#include<iostream>
#include<string>
#include<algorithm>
#include<cstdlib>
#include<cstdio>
#include<vector>
#include<cstring>
#include<cmath>
using namespace std;
int mm[735][735];
void B(int n,int x,int y)
{
    int i;
    if(n==1)
        mm[x][y]=1;
    else
    {
        B(n-1,x,y);
        B(n-1,x,y+2*pow(3.0,n-2));
        B(n-1,x+pow(3.0,n-2),y+pow(3.0,n-2));
        B(n-1,x+2*pow(3.0,n-2),y);
        B(n-1,x+2*pow(3.0,n-2),y+2*pow(3.0,n-2));
    }
}
int main()
{
    int n;
    int i,j;
    while(scanf("%d",&n)&&n!=-1)
    {
        memset(mm,0,sizeof(mm));
        if(n==1)
        {
            printf("X\n-\n");
        }
        else
        {
            B(n,0,0);
            for(i=0;i<pow(3.0,n-1);i++)
            {
                for(j=0;j<pow(3.0,n-1);j++)
                    if(mm[i][j]==1)
                        printf("X");
                    else
                        printf(" ");
                printf("\n");
            }
            printf("-\n");
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值