POJ 2083 Fractal

Fractal
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 6646 Accepted: 3297

Description

A fractal is an object or quantity that displays self-similarity, in a somewhat technical sense, on all scales. The object need not exhibit exactly the same structure at all scales, but the same "type" of structures must appear on all scales. 
A box fractal is defined as below : 
  • A box fractal of degree 1 is simply 
  • A box fractal of degree 2 is 
    X X 

    X X 
  • If using B(n - 1) to represent the box fractal of degree n - 1, then a box fractal of degree n is defined recursively as following 
    B(n - 1)        B(n - 1)
    
    B(n - 1)
    B(n - 1) B(n - 1)

Your task is to draw a box fractal of degree n.

Input

The input consists of several test cases. Each line of the input contains a positive integer n which is no greater than 7. The last line of input is a negative integer −1 indicating the end of input.

Output

For each test case, output the box fractal using the 'X' notation. Please notice that 'X' is an uppercase letter. Print a line with only a single dash after each test case.

Sample Input

1
2
3
4
-1

Sample Output

X
-
X X
 X
X X
-
X X   X X
 X     X
X X   X X
   X X
    X
   X X
X X   X X
 X     X
X X   X X
-
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
         X X   X X
          X     X
         X X   X X
            X X
             X
            X X
         X X   X X
          X     X
         X X   X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
   X X               X X
    X                 X
   X X               X X
X X   X X         X X   X X
 X     X           X     X
X X   X X         X X   X X
-
#include <stdio.h>
#include <math.h>
#include <iostream>
using namespace std;

char Map[1000][1000];

void DFS(int n, int x, int y)
{
    if (n == 1)
    {
        Map[x][y] = 'X';
        return;
    }
    int size = pow(3.0, n - 2);
    DFS(n - 1, x, y);//    左上角
    DFS(n - 1, x, y + size * 2);//右上角
    DFS(n - 1, x + size, y + size);//中间
    DFS(n - 1, x + size * 2, y);//左下角
    DFS(n - 1, x + size * 2, y + size * 2);//右下角
}

int main()
{
    int n, size;
    while(scanf("%d", &n) != NULL && n != -1)
    {
        size = pow(3.0, n - 1);
        for (int i = 0; i <= size; i++)
        {
            for (int j = 0; j <= size; j++)
            {
                Map[i][j] = ' ';
            }
            Map[i][size + 1] = '\0';
        }
        DFS(n, 1, 1);
        for (int i = 1; i <= size; i++)
        {
            printf("%s\n", Map[i] + 1);
        }
        printf("-\n");
    }
    return 0;
}

 

转载于:https://www.cnblogs.com/lzmfywz/p/3252235.html

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值