HDU 1829 A bug's life

 

Description

Background
Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs. 
Problem
Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.

Input

The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.

Output

The output for every scenario is a line containing "Scenario #i:", where i is the number of the scenario starting at 1, followed by one line saying either "No suspicious bugs found!" if the experiment is consistent with his assumption about the bugs' sexual behavior, or "Suspicious bugs found!" if Professor Hopper's assumption is definitely wrong.

Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.
 
 

 

废话不说上主题

解题思路:

1.这个题用并查集;

2.这个题有个坑点,回车坑;

3.给par数组开两个种类(加上个转移量),利用same比较每次输入的虫子是否是同性(同组) 如果搅基,利用变量记录;

4.我能开火车了,污,污。。。。

代码:

#include<algorithm>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<cctype>
#include<list>
#include<iostream>
#include<map>
#include<queue>
#include<set>
#include<stack>
#include<vector>

using namespace std;

int par[100020];
int rank[100000];

void init(int x)//初始化
{
    for(int i = 0; i < x; i++)
    {
         par[i] = i;
         rank[i] = 0;
    }
}
int find(int x)//查找根节点
{
    if(par[x] == x) return x;
    else
        return par[x] = find(par[x]);
}
void unite(int x, int y)//合并
{
    x = find(x);
    y = find(y);
    if(x == y) return ;
    if(rank[x] < rank[y])
         par[x] = y;
    else{
        par[y] = x;
        if(rank[x] == rank[y]) rank[x]++;
    }
}
bool same(int x, int y)//判断x, y是否是一组
{
    return par[x] == par[y];
}
int main()
{
    int n;
    scanf("%d",&n);
    for(int k = 0; k < n;k++)
    {
        int a,b,c,d;
        scanf("%d%d",&a,&b);
        init(2 * a);
        int txt = true;//记录变量
        for(int i = 0; i < b;i++)
        {
            scanf("%d%d",&c,&d);
            if(same(c,d))//判断是否是一组(同性)其实还有same(c + a,d + a)自己想去吧 
            {
                txt = false;
            }
            unite(c, d + a);//两个虫子异性合并
            unite(c + a,d);//同上
        }
        if(k) printf("\n");//不加这肯定TE
        if(!txt) printf("Scenario #%d:\nSuspicious bugs found!\n",k + 1);
        if(txt) printf("Scenario #%d:\nNo suspicious bugs found!\n",k + 1);
    }
    return 0;
}

 

队友版本:

 

 

 

#include <iostream>
#include<algorithm>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<cstdlib>
#include<stack>
#include<queue>

using namespace std;

int n,k;
int parent[1000000];

int find(int a)
{
    if(a!=parent[a])
        return parent[a]=find(parent[a]);
    else
        return parent[a];
}

void unite(int a,int b)
{
    a=find(a);
    b=find(b);
   parent[b]=a;
}

int main()
{
    int t,i,x,y,sum=1;
    scanf("%d",&t);
    while(t--)
   {
   scanf("%d%d",&n,&k);
   for(i=1;i<=n*2;i++)
   {
       parent[i]=i;
   }
   int ans=0;
    for(i=0;i<k;i++)
    {
        scanf("%d%d",&x,&y);
        if(find(x)==find(y))
        {
           ans=1;
        }
        else
            {

                unite(x,y+n);
                unite(x+n,y);
            }
    }
  printf("Scenario #%d:\n",sum++);
 if(ans==1)
    printf("Suspicious bugs found!\n");
  else
    printf("No suspicious bugs found!\n");
    if (t>0)
        printf("\n");
   }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值