HDU 1829 A Bug's Life

Background

Professor Hopper is researching the sexual behavior of a rare species of bugs. He assumes that they feature two different genders and that they only interact with bugs of the opposite gender. In his experiment, individual bugs and their interactions were easy to identify, because numbers were printed on their backs.

Problem

Given a list of bug interactions, decide whether the experiment supports his assumption of two genders with no homosexual bugs or if it contains some bug interactions that falsify it.
Input
The first line of the input contains the number of scenarios. Each scenario starts with one line giving the number of bugs (at least one, and up to 2000) and the number of interactions (up to 1000000) separated by a single space. In the following lines, each interaction is given in the form of two distinct bug numbers separated by a single space. Bugs are numbered consecutively starting from one.
Output
The output for every scenario is a line containing “Scenario #i:”, where i is the number of the scenario starting at 1, followed by one line saying either “No suspicious bugs found!” if the experiment is consistent with his assumption about the bugs’ sexual behavior, or “Suspicious bugs found!” if Professor Hopper’s assumption is definitely wrong.
Sample Input

2
3 3
1 2
2 3
1 3
4 2
1 2
3 4

Sample Output

Scenario #1:
Suspicious bugs found!

Scenario #2:
No suspicious bugs found!

Hint

Huge input,scanf is recommended.

题意描述:

就是让你看有没有一个对多个的现象出现。

解题思路

开一个数组进行标记,初始时都标记为成1,然后如果和一个配对上,改变其标记。

#include<stdio.h>

int n,f[2100],x[2100],flag;

void inti()
{
	for(int i=1;i<=n;i++)
	{
		f[i]=i;
		x[i]=1;
	}
	return ;
}

int getf(int i)
{
	//printf("$%d %d$\n",i,x[i]);
	//printf("-*%d %d*-\n",i,f[i]);
	if(f[i]==i)
		return i;
//	printf("++++\n");
	int tmp=f[i];
	f[i]=getf(tmp);
	
	//printf("@%d %d@\n",f[i],i);
	x[i]=(x[i]+x[tmp]+1)%2;
	return f[i];	
}

void merge(int a,int b)
{
	int t1,t2;
	t1=getf(a);
	t2=getf(b);
	if(t1!=t2)
	{
		//printf("%d**%d*\n",t1,t2);
		f[t2]=t1;
		x[t2]=(x[a]+x[b])%2;
	}
	else
	{
	//	printf("*%d %d %d %d*\n",a,b,x[a],x[b]);
		if((x[a]+x[b])%2==0)
			flag=1;
	}
}

int main(void)
{
	int a,b,m,t,t1=1;

	scanf("%d",&t);
	while(t--)
	{
		scanf("%d%d",&n,&m);
		flag=0;	
		inti();
		while(m--)
		{ 
			scanf("%d%d",&a,&b);
			merge(a,b);
		}
//		for(int i=1;i<=n;i++)
//			printf("%d ",x[i]);
		printf("Scenario #%d:\n",t1++);
		if(flag==1)
			printf("Suspicious bugs found!\n");
		else
			printf("No suspicious bugs found!\n");
		printf("\n");
	}
	return 0;
	
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值