1020. Tree Traversals

Suppose that all the keys in a binary tree are distinct positive integers. Given the postorder and inorder traversal sequences, you are supposed to output the level order traversal sequence of the corresponding binary tree.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (<=30), the total number of nodes in the binary tree. The second line gives the postorder sequence and the third line gives the inorder sequence. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the level order traversal sequence of the corresponding binary tree. All the numbers in a line must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:
7
2 3 1 5 7 6 4
1 2 3 4 5 6 7
Sample Output:

4 1 6 3 5 7 2

#include <cstdio>
#include <cstdlib>
#include<iostream>
using namespace std;
#include <deque>
#include <queue>
#include <string>
#include <vector>
#include <iomanip>
#include<algorithm>
#include<math.h>
#include<queue>
using namespace std;
#define max1 600
#define inf 1000
typedef struct Node
{
    int data;
    struct Node *Lchild;
    struct Node *Rchild;
}*Tree;
typedef struct Lnode
{
    int a[max1];
    int real,font;
    int size;
}*queue1;
queue1 createQueue()
{
    queue1 s;
    s->font=0;
    s->real=0;
    s->size=0;
    return s;
}
void InQueue(queue1 *s,Tree *g)
{
    if((*s)->real==max1)
    {
        cout<<"FULL";
        return;
    }
    (*s)->a[(*s)->real++]=(*g)->data;
}
int Empty(queue1 s)
{
    if(s->real==s->font)
        return 1;
    else
        return 0;
}
void DeQueue(queue1 *s,Tree *g)
{
    if((*s)->font==(*s)->real)
    {
        cout<<"Empty";
        return;
    }
    (*g)->data=(*s)->a[(*s)->font--];
}
void buildTree(Tree *s,int a[],int b[],int af,int ae,int bf,int be)
{
    *s=(Tree)malloc(sizeof(struct Node));
    (*s)->data=a[ae];
    (*s)->Lchild=NULL;
    (*s)->Rchild=NULL;
    int g=bf;
    while(a[ae]!=b[g])
        g++;
    int len=g-bf;
    if(g>bf)
        buildTree(&(*s)->Lchild,a,b,af,af+len-1,bf,g-1);
    if(be>g)
        buildTree(&(*s)->Rchild,a,b,af+len,ae-1,g+1,be);
}
void visit(Tree a)
{
    cout<<a->data;
}
void CenXu(Tree s)
{
    queue<Tree> g;
    Tree a;
    int lag=1;
    g.push(s);
    while(!g.empty())
    {
        if(lag)
            lag=0;
        else
            cout<<' ';
        a=g.front();
        visit(a);
        g.pop();
        if(a->Lchild)
            g.push(a->Lchild);
        if(a->Rchild)
            g.push(a->Rchild);
    }
}
int main()
{
  Tree s=NULL;
  queue1 g;
  int n,i;
  cin>>n;
  int a[n],b[n];
  for(i=0;i<n;i++)
    cin>>a[i];
  for(i=0;i<n;i++)
    cin>>b[i];
  buildTree(&s,a,b,0,n-1,0,n-1);
  CenXu(s);
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值