1023. Have Fun with Numbers

Notice that the number 123456789 is a 9-digit number consisting exactly the numbers from 1 to 9, with no duplication. Double it we will obtain 246913578, which happens to be another 9-digit number consisting exactly the numbers from 1 to 9, only in a different permutation. Check to see the result if we double it again!

Now you are suppose to check if there are more numbers with this property. That is, double a given number with k digits, you are to tell if the resulting number consists of only a permutation of the digits in the original number.

Input Specification:

Each input file contains one test case. Each case contains one positive integer with no more than 20 digits.

Output Specification:

For each test case, first print in a line "Yes" if doubling the input number gives a number that consists of only a permutation of the digits in the original number, or "No" if not. Then in the next line, print the doubled number.

Sample Input:
1234567899
Sample Output:
Yes

2469135798


#include <cstdio>
#include <cstdlib>
#include<iostream>
using namespace std;
#include <deque>
#include <queue>
#include <string>
#include <vector>
#include <iomanip>
#include<algorithm>
#include<math.h>
#include<queue>
#define max1 21
using namespace std;
int a[25];
int g[10]={0};
int add(string s,int n)
{
    int num,i,h=0,q;
    for(i=n-1;i>=0;i--)
    {
        num=s[i]-'0';
        g[num]++;
        a[i]=num;
    }
    for(i=n-1;i>0;i--)
    {
        a[i]=a[i]*2;
        a[i]+=h;
        h=a[i]/10;
        a[i]%=10;
    }
    a[i]=a[i]*2;
    a[i]+=h;
    h=a[i]/10;
    a[i]%=10;
    if(h)
    {
        for(i=n;i>0;i--)
        {
            a[i]=a[i-1];
        }
        a[i]=h;
        return n+1;
    }
    else
        return n;
}
int isRight(int n,int num)
{
    int i;
    if(n!=num)
        return 0;
    for(i=0;i<n;i++)
    {
        g[a[i]]--;
    }
    for(i=0;i<10;i++)
    {
        if(g[i]!=0)
            return 0;
    }
    return 1;
}
int main()
{
  string s;
  int i,n;
  cin>>s;
  n=s.length();
  n=add(s,s.length());
  if(isRight(n,s.length()))
    cout<<"Yes"<<endl;
  else
    cout<<"No"<<endl;
  for(i=0;i<n;i++)
    cout<<a[i];
  return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值