UVA 216 (13.07.19)

 Getting in Line 

Computer networking requires that the computers in the network be linked.

This problem considers a ``linear" network in which the computers are chainedtogether so that each is connected to exactly two others except for the two computers on the ends of the chain which are connected to only one other computer. A picture is shown below. Here the computers are the black dots and their locations in the network are identified by planar coordinates (relative to a coordinate system not shown in the picture).

Distances between linked computers in the network are shown in feet.

For various reasons it is desirable to minimize the length of cable used.

Your problem is to determine how the computers should be connected into such a chain to minimize the total amount of cable needed. In the installation being constructed, the cabling will run beneath the floor, so the amount of cable used to join 2 adjacent computers on the network will be equal to the distance between the computers plus 16 additional feet of cable to connect from the floor to the computers and provide some slack for ease of installation.

The picture below shows the optimal way of connecting the computers shownabove, and the total length of cable required for this configuration is (4+16)+ (5+16) + (5.83+16) + (11.18+16) = 90.01 feet.

Input

The input file will consist of a series of data sets. Each data set will begin with a line consisting of a single number indicating the number of computers in a network. Each network has at least 2 and at most 8 computers. A value of 0 for the number of computers indicates the end of input.

After the initial line in a data set specifying the number of computers in a network, each additional line in the data set will give the coordinates of a computer in the network. These coordinates will be integers in the range 0 to 150. No two computers are at identical locations and each computer will be listed once.

Output

The output for each network should include a line which tells the number of the network (as determined by its position in the input data), and one line for each length of cable to be cut to connect each adjacent pair of computers in the network. The final line should be a sentence indicating the total amount of cable used.

In listing the lengths of cable to be cut,traverse the network from one end to the other. (It makes no difference atwhich end you start.) Use a format similar to the one shown in the sample output, with a line of asterisks separating output for different networks and with distances in feet printed to 2 decimal places.

Sample Input

6
5 19
55 28
38 101
28 62
111 84
43 116
5
11 27
84 99
142 81
88 30
95 38
3
132 73
49 86
72 111
0

Sample Output

**********************************************************
Network #1
Cable requirement to connect (5,19) to (55,28) is 66.80 feet.
Cable requirement to connect (55,28) to (28,62) is 59.42 feet.
Cable requirement to connect (28,62) to (38,101) is 56.26 feet.
Cable requirement to connect (38,101) to (43,116) is 31.81 feet.
Cable requirement to connect (43,116) to (111,84) is 91.15 feet.
Number of feet of cable required is 305.45.
**********************************************************
Network #2
Cable requirement to connect (11,27) to (88,30) is 93.06 feet.
Cable requirement to connect (88,30) to (95,38) is 26.63 feet.
Cable requirement to connect (95,38) to (84,99) is 77.98 feet.
Cable requirement to connect (84,99) to (142,81) is 76.73 feet.
Number of feet of cable required is 274.40.
**********************************************************
Network #3
Cable requirement to connect (132,73) to (72,111) is 87.02 feet.
Cable requirement to connect (72,111) to (49,86) is 49.97 feet.
Number of feet of cable required is 136.99.

题意是这样的:
有N台电脑, 然后一条网线装过去, 要求网线最短~ (注意, 一条连到底的网线, 不许分叉)
输入的是N, 随后N个坐标
然后输出应该不用说了, 直接看样例都懂了, 这里还有一个注意点, 每两台电脑间的距离算完要+16! 做法: 用next_permutation函数, 全排列N台电脑的顺序 对每个顺序的每两台电脑间距离 以及 总距离 进行记录~ 每个顺序的距离计算完后, 与先前的最短距离比较, 当前顺序的距离小于之前的最短距离, 更新之~ 第一次做错的思路: 从第一个点开始判断, 找出与之最短距离的点, 连上. 然后连上的点送入DFS(next), 再找与之最短距离的点, 连上, 如此下去 后来发现错误之处是这样的: 假设五个点, 前四个点的每次判断找出与之距离最短的点属于贪心法, 这样一来, 前四个点无疑是最优解了 但是, 问题就出在第五个点, 因为Wrong的代码是用DFS连接点的, 导致第五点只能跟好的第四点, 即末端相连 于是, 第五点不一定是最优解, 因为也许此时的第五点可与连好的第一个点, 即首端相连 也就是说, 第五点有两个选择, 连首端或末端, 而我Wrong的程序只能连在末端, 导致出错! 下面是代码, Wrong的代码方法较好, 但是需要修改 AC的代码带有暴力的手段~ 
下面先贴出AC代码 随后一份是我第一次做错时的代码

AC代码:
#include<stdio.h>
#include<algorithm>
#include<math.h>

using namespace std;

int cpt[10][2];
int ans[10+1];
int Sort[10];
int N;
int cas = 0;
double sum;
double ans_sum;
double stepDis[10];
double ans_stepDis[10];

int main() {
	while(scanf("%d", &N) != EOF) {
		if(N == 0)	
			break;
		for(int i = 1; i <= N; i++)
			Sort[i] = i;
		for(int i = 1; i <= N; i++)
			scanf("%d%d", &cpt[i][0], &cpt[i][1]);
		ans_sum = 25000;
		do{
			sum = 0;
			for(int i = 1; i < N; i++) {
				int tx, ty;
				double dis;
				tx = cpt[Sort[i]][0] - cpt[Sort[i+1]][0];
				ty = cpt[Sort[i]][1] - cpt[Sort[i+1]][1];
				dis = sqrt(tx * tx + ty * ty) + 16;
				stepDis[i] = dis;
				sum += stepDis[i];
			}
			if(sum <= ans_sum) {
				for(int i = 1; i <= N; i++) {
					ans[i] = Sort[i];
					ans_stepDis[i] = stepDis[i];
				}
				ans_sum = sum;
			}
		}
		while(next_permutation(Sort+1, Sort+1+N));
		printf("**********************************************************\n");
		printf("Network #%d\n", ++cas);
		for(int i = N-1; i > 0; i--) {
			printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n", cpt[ans[i+1]][0], cpt[ans[i+1]][1], cpt[ans[i]][0], cpt[ans[i]][1], ans_stepDis[i]);
		}
		printf("Number of feet of cable required is %.2lf.\n", ans_sum);
	}
	return 0;
}

Wrong的代码:
#include<stdio.h>
#include<string.h>
#include<math.h>

int cpt[10][2];
int mark[10];
int N;
double sum;
int count;
int cas = 0;

void DFS(int n) {
	int min = 25000;
	int disx, disy;
	int D;
	int next;
	double dis;
	if (count == N-1)
		return ;
	for (int i = 0; i < N; i++) {
	   	if (n == i || mark[i] == 1)	
			continue;
		else {
			disx = cpt[n][0] - cpt[i][0];
			disy = cpt[n][1] - cpt[i][1];
			D = disx * disx + disy * disy;
			if (D <= min) {
				min = D;
				next = i;
			}
		}
	}
	mark[next] = 1;
	dis = sqrt(min) + 16;
	sum += dis;
	count++;
	printf("Cable requirement to connect (%d,%d) to (%d,%d) is %.2lf feet.\n", cpt[n][0], cpt[n][1], cpt[next][0], cpt[next][1], dis);
	DFS(next);
}

int main() {
	while (scanf("%d", &N) != EOF) {
		if (N == 0)	
			break;
		sum = 0;
		count = 0;
		memset (mark, 0, sizeof(mark));
		for (int i = 0; i < N; i++)
			scanf("%d%d", &cpt[i][0], &cpt[i][1]);
		printf("**********************************************************\n");
		printf("Network #%d\n", ++cas);
		mark[0] = 1;
		DFS(0);
		printf("Number of feet of cable required is %.2lf.\n", sum);
	}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值