HDU 3732 (13.07.25)

Ahui Writes Word

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1607    Accepted Submission(s): 608


Problem Description
We all know that English is very important, so Ahui strive for this in order to learn more English words. To know that word has its value and complexity of writing (the length of each word does not exceed 10 by only lowercase letters), Ahui wrote the complexity of the total is less than or equal to C.
Question: the maximum value Ahui can get.
Note: input words will not be the same.
 

Input
The first line of each test case are two integer N , C, representing the number of Ahui’s words and the total complexity of written words. (1 ≤ N ≤ 100000, 1 ≤ C ≤ 10000)
Each of the next N line are a string and two integer, representing the word, the value(Vi ) and the complexity(Ci ). (0 ≤ Vi , Ci ≤ 10)
 

Output
Output the maximum value in a single line for each test case.
 

Sample Input
  
  
5 20 go 5 8 think 3 7 big 7 4 read 2 6 write 3 5
 

Sample Output
 
 
15
Hint
Input data is huge,please use “scanf(“%s”,s)” 题意: 学不同的英语单词有不同的收获价值和不同的复杂度 给出N, 代表N个单词, 再给出C, 代表总复杂度 在不超过总复杂度的情况下, 要求收获最大 例如样例中的 go单词 价值度是5, 复杂度是20 而且这题的数据是会重复的, 所以数组只开11的大小就行了 再把多重背包的问题转化为01背包~ AC代码:
#include<stdio.h>
#include<string.h>

int DP[10001];
int N, C;

void pickThing(int v, int c, int n){
	for(int k = 1; n > 0; k += k) {
		if(k > n)
			k = n;
		n -= k;
		int vv, cc;
		vv = k * v;
		cc = k * c; 
		for(int i = C; i >= cc; i--)
			if(DP[i] < DP[i-cc] + vv)
				DP[i] = DP[i-cc] + vv;
	} 
} 

int main() {
	int map[12][12];
	char name[20];
	int v, c;
	while(scanf("%d %d", &N, &C) != EOF) {
		memset(map, 0, sizeof(map));
		for(int i = 0; i < N; i++) {
			scanf("%s%d%d", name, &v, &c);
			map[v][c]++;
		}
		memset(DP, 0, sizeof(DP));
		for(int i = 1; i <= 10; i++) {
			for(int j = 0; j <= 10; j++) {
				if(map[i][j])
					pickThing(i, j, map[i][j]);
			}
		}
		printf("%d\n", DP[C]);
	}
	return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值