ACM--Moving Tables

Description

The famous ACM (Advanced Computer Maker) Company has rented a floor of a building whose shape is in the following figure. 



The floor has 200 rooms each on the north side and south side along the corridor. Recently the Company made a plan to reform its system. The reform includes moving a lot of tables between rooms. Because the corridor is narrow and all the tables are big, only one table can pass through the corridor. Some plan is needed to make the moving efficient. The manager figured out the following plan: Moving a table from a room to another room can be done within 10 minutes. When moving a table from room i to room j, the part of the corridor between the front of room i and the front of room j is used. So, during each 10 minutes, several moving between two rooms not sharing the same part of the corridor will be done simultaneously. To make it clear the manager illustrated the possible cases and impossible cases of simultaneous moving. 



For each room, at most one table will be either moved in or moved out. Now, the manager seeks out a method to minimize the time to move all the tables. Your job is to write a program to solve the manager’s problem. 
 

Input

The input consists of T test cases. The number of test cases ) (T is given in the first line of the input. Each test case begins with a line containing an integer N , 1<=N<=200 , that represents the number of tables to move. Each of the following N lines contains two positive integers s and t, representing that a table is to move from room number s to room number t (each room number appears at most once in the N lines). From the N+3-rd line, the remaining test cases are listed in the same manner as above. 
 

Output

The output should contain the minimum time in minutes to complete the moving, one per line. 
 

Sample Input

    
    
3 4 10 20 30 40 50 60 70 80 2 1 3 2 200 3 10 100 20 80 30 50
 

Sample Output

10

20

30


//此题采用贪心的思想 
//在输入数据的时候应该进行预处理,对输入的两个房间号进行判断,小的作为start,大的作为end。 
//将两个房间号视为一个区间。然后将所有的区间以start升序排序 
//判断两个区间是否有shared part:判断前一个区间的尾是否大于等于后一个区间的头。 
//不过应做奇偶判断。如(1,4) (3,6) 实际上等价于(1,2) (2,3),可知有shared part. 
//贪心做法是,从第一个区间开始,找下一个与之不重叠的区间。重复进行,可知这些区间可以同时搬桌子 
//将这些不重叠的区间删除,做法是一个标记变量IsDel.此时问题规模减少。重复上一步,从当前第一个区间开始 

#include<iostream>
#include<algorithm>
using namespace std;
struct room
{
	int start;
	int end;
	bool IsDel;
}a[205];
bool cmp(room a,room b)
{
	a.start=a.start<a.end?a.start:a.end;
	b.start=b.start<b.end?b.start:b.end;		 
	if(a.start<b.start)
	  return true;
	else
	  return false;
}
bool IsConflict(room a,room b)//判断两个区间是否不能同时搬
{   
    a.end=a.end>a.start?a.end:a.start;
    b.start=b.start<b.end?b.start:b.end;
	int e=a.end%2?(a.end+1)/2:a.end/2;
	int s=b.start%2?(b.start+1)/2:b.start/2;
	if(e>=s)
	  return true;
	else
	  return false;	
} 
int main()
{
   int Case;
   cin>>Case;
   while(Case--)
   {
   	 int n;
   	 cin>>n;
   	 for(int i=1;i<=n;i++)
   	{
   	  cin>>a[i].start>>a[i].end;
   	   a[i].IsDel=false;
   	}
   	 sort(a+1,a+1+n,cmp);
   	 int sum=0;
   	 for(int i=1;i<=n;i++)
   	 { 
   	 	if(a[i].IsDel)
   	 	  continue;
   	 	sum+=10;
   	 	room temp=a[i];
   	 	for(int j=i+1;j<=n;j++)
   	 	{
   	 		if(a[j].IsDel)
   	 		  continue;
   	 		if(!IsConflict(temp,a[j]))
   	 		  {
   	 		    a[j].IsDel=true;
   	 		    temp=a[j];
   	 		  }   			
   	 	}	 
	}	 
	 cout<<sum<<endl;	 
   }
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值