HDOJ 2616 Kill the monster (DFS)

Kill the monster

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 180 Accepted Submission(s): 129
 
Problem Description
There is a mountain near yifenfei’s hometown. On the mountain lived a big monster. As a hero in hometown, yifenfei wants to kill it. 
Now we know yifenfei have n spells, and the monster have m HP, when HP <= 0 meaning monster be killed. Yifenfei’s spells have different effect if used in different time. now tell you each spells’s effects , expressed (A ,M). A show the spell can cost A HP to monster in the common time. M show that when the monster’s HP <= M, using this spell can get double effect.
 
Input
The input contains multiple test cases.
Each test case include, first two integers n, m (2<n<10, 1<m<10^7), express how many spells yifenfei has.
Next n line , each line express one spell. (Ai, Mi).(0<Ai,Mi<=m).
 
Output
For each test case output one integer that how many spells yifenfei should use at least. If yifenfei can not kill the monster output -1.
 
Sample Input
3 100
10 20
45 89
5  40

3 100
10 20
45 90
5 40

3 100
10 20
45 84
5 40
 
Sample Output
3
2
-1
 
Author
yifenfei
 
Source
奋斗的年代
 
Recommend
yifenfei
 

这道DFS题,和选取的法术顺序有关系。不是简单的选或者不选两种情况。

注意剪枝。

#include<iostream>  
#include<cstdio>  
#include<cstring>  
#include<algorithm>  
#include<cmath>  
using namespace std;
#define INF 0x3f3f3f
int n, m;
struct Spell//法术总类
{
	int a;
	int b;
}s[15];
int v[15];
int ans;
void dfs(int index, int hp,int cnt)//数组下标  血量  选中的法术次数
{
	
	if (hp <= 0) { if (cnt < ans)ans = cnt; return; }//找到就回去  剪枝
	for (int i = 0; i < n; i++)//每个顺序都要DFS一次
	{
		if (v[i] == 0)
		{
			v[i] = 1;
			if (hp <= s[i].b)
			{
				dfs(i, hp - 2 * s[i].a, cnt + 1);
			}
			else
			{
				dfs(i, hp - s[i].a, cnt + 1);
			}
			v[i] = 0;
		}

	}
}


int main()
{
	while (scanf("%d%d",&n,&m)!=EOF)
	{
		for (int i = 0; i <n; i++)
		{
			scanf("%d%d", &s[i].a,&s[i].b);
		}
	ans = INF;
	for (int i = 0; i < n; i++)//将每种法术放在第一个顺序DFS一遍
	{
		memset(v, 0, sizeof(v));
		for (int j = 0; j < i; j++)//这样就不会出现重复的DFS  剪枝
		{
			v[j] = 1;
		}
		dfs(i,m,0);
	}

	
	if (ans == INF)printf("-1\n");//找到最小的。
	else printf("%d\n", ans);
	}

	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值