HDOJ 1394 Minimum Inversion Number(线段树+逆序数)

Minimum Inversion Number

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 21463    Accepted Submission(s): 12851


Problem Description
The inversion number of a given number sequence a1, a2, ..., an is the number of pairs (ai, aj) that satisfy i < j and ai > aj.

For a given sequence of numbers a1, a2, ..., an, if we move the first m >= 0 numbers to the end of the seqence, we will obtain another sequence. There are totally n such sequences as the following:

a1, a2, ..., an-1, an (where m = 0 - the initial seqence)
a2, a3, ..., an, a1 (where m = 1)
a3, a4, ..., an, a1, a2 (where m = 2)
...
an, a1, a2, ..., an-1 (where m = n-1)

You are asked to write a program to find the minimum inversion number out of the above sequences.
 

Input
The input consists of a number of test cases. Each case consists of two lines: the first line contains a positive integer n (n <= 5000); the next line contains a permutation of the n integers from 0 to n-1.
 

Output
For each case, output the minimum inversion number on a single line.
 

Sample Input
  
  
10 1 3 6 9 0 8 5 7 4 2
 

Sample Output
  
  
16
 

Author
CHEN, Gaoli
 

Source
 

Recommend
Ignatius.L   |   We have carefully selected several similar problems for you:   1166  1698  1540  1542  1255 
 



建立一个空的线段树,每加入一个元素,查询线段树里大于这个元素的的个数有多少个,即此时产生了多少对逆序数。

当建立好线段树以后,每将头位置的数例如k,放到末尾。减少了k个逆序数,因为在变换之前,K位置后面,有K个数小于K;同时又增加了n-k-1个逆序数,因为变换之后,k前面有n-1-k个数大于k.

如: 2 1 0   逆序数 3

      1 0 2   逆序数 1(3-2+2-2)

      0 2 1   逆序数 1 (1-1+2-1)

#include<iostream>
#include<algorithm>
#include<cstdio>
#include<cstring>
#include<cmath>
#include<string>

const int MAX_N = 5000;
int pos;

int dat[MAX_N<<2];
int a[MAX_N + 10];

using namespace std;


void update(int k)//更新
{
	while (k>0)
	{
		k = (k - 1) / 2;
		dat[k] = dat[2 * k + 1] + dat[2 * k + 2];
	}
}

//求[a,b)之间的和
//k 是节点编号, l和r表示对应[l,r)区间
int querya(int a, int b,int k,int l,int r)
{
	int ans=0;
	//[a,b)和[l,r)不相交
	if (r <= a || b <= l)return 0;
	//[a,b)完全包含[l,r)
	if (a <= l&&r <= b)return dat[k];
	else 
	{
		//左边的和+右边的和
		ans += querya(a, b, k * 2 + 1, l, (l + r) / 2);
		ans += querya(a, b, k * 2 + 2, (l + r) / 2,r );
		return ans;
	}

}

int main()
{
	int n;
	while (scanf("%d",&n)!=EOF)
	{
		memset(dat, 0, sizeof(dat));
		int sum = 0;
		pos = 1;
		while (pos<n)
		{
			pos *= 2;
		}
		pos--;//叶子的第一个节点是pos-1
		for (int i = 0; i < n; i++)
		{
			
			scanf("%d", &a[i]);
			int t = a[i];
			dat[pos + t] = 1;
			update(pos + t);
			sum += querya(0, pos + 1, 0, 0, pos + 1) - querya(0, t + 1, 0, 0, pos + 1);
		}
		int ans = sum;
		for (int i = 0; i < n; i++)
		{
			sum = sum - a[i] + n - 1 - a[i];
			ans = min(sum, ans);
		}
		printf("%d\n", ans);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值