HDOJ 2852 KiKi's K-Number (树状数组+二分查找)

KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 240 Accepted Submission(s): 97
 
Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 
Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 
Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 
Sample Input
5
0 5
1 2
0 6
2 3 2
2 8 1
7
0 2
0 2
0 4
2 1 1
2 1 2
2 1 3
2 1 4
 
Sample Output
No Elment!
6
Not Find!
2
2
4
Not Find!
 
 
Source
2009 Multi-University Training Contest 4 - Host by HDU
 
Recommend
gaojie
 



#include<iostream>
#include<algorithm>
#include<cstring>
#include<cstdio>
#include<cmath>

using namespace std;

const int MAX_N = 100010;

int bit[MAX_N+100];
int n;

int sum(int i)
{
	int s = 0;
	while (i>0)
	{
		s += bit[i];
		i -= i&-i;
	}
	return s;
}

void add(int i, int x)
{
	while (i <= n)
	{
		bit[i] += x;
		i += i&-i;
	}
}
int find(int a, int k)
{
	int cnt;
	cnt = sum(a) + k;
	int first = a;
	int last = n;
	while (first+1<last)
	{
		int mid = (first + last) / 2;
		if (sum(mid)<cnt)
		{
			first = mid;
		}
		else
		{
			last = mid;
		}
	}
	return last;
}

int main()
{
	int m;
	while (scanf("%d",&m)!=EOF)
	{
		n = MAX_N;
		memset(bit, 0, sizeof(bit));
		while (m--)
		{
			int p, a, k, e;
			scanf("%d", &p);
			if (p == 0)
			{
				scanf("%d", &e);
				add(e, 1);
			}
			else if (p == 1)
			{
				scanf("%d", &e);
				if ((sum(e) - sum(e - 1)) == 0)//e=(0,e]-(0,e-1]
				{
					puts("No Elment!");
					continue;
				}
				add(e, -1);
			}
			else if (p == 2)
			{
				scanf("%d%d", &a,&k);
				if ((sum(n) - sum(a)) < k)
				{
					puts("Not Find!");
					continue;
				}
				printf("%d\n", find(a, k));
			}
		}
		
	}
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值