HDU 2852 KiKi's K-Number 树状数组




KiKi's K-Number

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1593    Accepted Submission(s): 677


Problem Description
For the k-th number, we all should be very familiar with it. Of course,to kiki it is also simple. Now Kiki meets a very similar problem, kiki wants to design a container, the container is to support the three operations.

Push: Push a given element e to container

Pop: Pop element of a given e from container

Query: Given two elements a and k, query the kth larger number which greater than a in container;

Although Kiki is very intelligent, she can not think of how to do it, can you help her to solve this problem?
 

Input
Input some groups of test data ,each test data the first number is an integer m (1 <= m <100000), means that the number of operation to do. The next m lines, each line will be an integer p at the beginning, p which has three values:
If p is 0, then there will be an integer e (0 <e <100000), means press element e into Container.

If p is 1, then there will be an integer e (0 <e <100000), indicated that delete the element e from the container  

If p is 2, then there will be two integers a and k (0 <a <100000, 0 <k <10000),means the inquiries, the element is greater than a, and the k-th larger number.
 

Output
For each deletion, if you want to delete the element which does not exist, the output "No Elment!". For each query, output the suitable answers in line .if the number does not exist, the output "Not Find!".
 

Sample Input
  
  
5 0 5 1 2 0 6 2 3 2 2 8 1 7 0 2 0 2 0 4 2 1 1 2 1 2 2 1 3 2 1 4
 

Sample Output
  
  
No Elment! 6 Not Find! 2 2 4 Not Find!
 

忘记了初始化找了好久的BUG。。。。

这道题的操作有三种,插入和删除并到一个函数里完成 ,查询的操作要用到二分的方法。


#include <cstdio>
#include <string.h>
#include <stdlib.h>
#include <algorithm>
using namespace std;
const int M = 100005;
int num[M];
int lowbit( int x )
{
    return x&(-x);    
}

void add( int x , int val )
{
    while( x < M )
    {
           num[x] += val;
           x += lowbit(x);
    }
}



int sum( int x )
{
    int ret = 0;
    while( x > 0 )
    {
           ret += num[x];
           x -= lowbit(x);
    }
    return ret;
}

int find( int pos , int k )
{
    int neww = sum(pos);
    int l , r , m;
    l = pos + 1;
    r = M - 1;
    int ans = M;
    int total = 0;
    while( l <= r )
    {
           m = ( l+r ) / 2;
           total = sum(m) - neww;
           if( total >= k )
           {
               r = m - 1;
               if( m < ans )
                   ans = m;
           }
           else
               l = m + 1;
    }
    return ans;
}

int main( )
{
    int n;
    int c,x,y;
    while( scanf("%d",&n) != EOF )    
    {
           memset( num , 0 , sizeof(num) );
           while( n-- ){
                  scanf("%d",&c);
                  if( c == 0 ){
                      scanf("%d",&x);
                      add( x , 1 ); 
                  }
                  else if( c == 1 ){
                       scanf("%d",&x);
                       if( sum(x) - sum(x-1) == 0 )
                           printf("No Elment!\n");
                       else
                           add( x , -1 );
                  }
                  else if( c == 2 ){
                       scanf("%d%d",&x,&y);
                       int ret = find( x , y );
                       if( ret == M )
                           printf("Not Find!\n");
                       else
                           printf("%d\n",ret);
                  }
           }
               
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值