1009: Tom数

题目

Description

正整数的各位数字之和被Tom称为Tom数。求输入数(<2^32)的Tom数!

Input

每行一个整数(<2^32).

Output

每行一个输出,对应该数的各位数之和.

Sample Input

12345
56123
82
Sample Output

15
17
10

/**
解析:主要是将每一位拆解出来并加起来
*/

代码块

import java.math.BigInteger;
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner cn = new Scanner(System.in);
        while (cn.hasNext()) {
            int s = cn.nextInt();
            System.out.println(maths(s));
        }
    }

    private static int maths(int s) {
        int sum = 0;
        while(s!=0){
            sum+=s%10;
            s/=10;
        }
        return sum;
    }
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值