1009:Tom数

1009:Tom数


Description


正整数的各位数字之和被Tom称为Tom数。求输入数(n<2^32)的Tom数!


Input


每行一个整数(n<2^32)。


Output


每行一个输出,对应该数的各位 数之和。


Sample Input


12345

56123

82


Sample output


15

17

10


#include<iostream>
#include<stdio.h>
using namespace std;
int main()
{
    int i;
    int n;
   int s;
 
    while(1==scanf("%d",&n))
    {
int count=0;
       int i=0;
       while(n/10!=0)
       {
 
           s=n%10;
           n=n/10;
           i++;
       count=count+s;
 
       }
 
      if(n/10==0)
            count=count+n;
 cout<<count<<endl;
 
    }


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值