题目
Description
一个整数,只知道前几位,不知道末二位,被另一个整数除尽了,那么该数的末二位该是什么呢
Input
输入数据有若干组,每组数据包含二个整数a,b(0<a<10000, 10<b<100),若遇到0 0则处理结束
Output
对应每组数据,将满足条件的所有尾数在一行内输出,格式见样本输出。同组数据的输出,其每个尾数之间空一格,行末没有空格。
Sample Input
200 40
1992 95
0 0
Sample Output
00 40 80
15
代码块
//这道题主要是难在行末没有空格,
import java.util.Scanner;//输入包
public class Main {
public static void main(String[] args) {
Scanner cn = new Scanner(System.in);//输入流
while (cn.hasNext()) {
int n = cn.nextInt();
int m = cn.nextInt();
if (n == 0 && m == 0)
return;//进行判断,是否进行退出
int i;
for (i = 0; i < 100; i++) {
int z = n * 100 + i;
if (i < 10 && z % m == 0)//如果是个位数,就需要进行多输出一位零
System.out.print(0);
if (z % m == 0) {//进行输出第一个满足条件的数,并跳出来
System.out.print(i);
break;
}
}
for(int j=0;j<100;j++){//进行输出之后满足条件的数,并在输出数之前输出空格
int z = n * 100 + j;
if(z%m==0&&j!=i){
System.out.print(" "+j);
}
}
System.out.println();
}
}
}